cant browse using wireless connection

July 31, 2009 at 21:30:37
Specs: Windows XP

I hope someone can help me with this problem. I have a laptop that I bought 2nd hand. I have problems browsing to the internet when I hook it up on wireless. I can get a good IP address and can ping a website but I can't seem to browse. I already manually added my ISPs preferred DNS settings. I can seem to access a website after the computer reboots but I could only get to the first page, once I try to click on a link or open a different website it wont load up anymore. I also noticed that when I tried connecting my laptop straight to the modem using an ethernet cable I am able to browse anywhere on the internet. I also tried to use my laptop on wireless at my office wireless network and it can browse pretty much anything.

I am really confused why it can browse with ethernet and wireless(at work) but can't browse to the internet at home using wireless.

By the way I have a 2wire modem at home.

See More: cant browse using wireless connection

Report •

July 31, 2009 at 21:37:06
Sounds like the problem is not in your computer. Have you tried hooking other computers to your WiFi?

What version of Windows are you running?

If it is a 2wire it will use a WEP encryption to connect the WiFi. You can find the modems WEB on the bottom. When you connect to it does it ask for the security key?

Report •

July 31, 2009 at 21:55:47
thanks for the reply..

nope I haven't tried connecting other computers to my wireless network since I don't have any other wireless computer to try it on. my other computer is a desktop computer with no wireless adapter and it's working fine. I can actually open the UI of the modem and can change my wireless settings. My wireless shows connected though.

Report •

July 31, 2009 at 22:07:29
Just because it is connected does not mean it is handshaking. WEP uses an OPEN authentication (This is why it can be hacked so easy) which means it will connect but will not pass packets that are not properly encrypted. So again did your computer ask for a password when you connected? What version of Windows are you running? Without answers to these questions we can not help.

Report •

Related Solutions

July 31, 2009 at 22:31:48
yes it did ask for a password i have set it to use my default WEP . I have windows XP SP2 .

Report •

August 1, 2009 at 01:00:06
You should have the laptop set to obtain IP automatically and the router"s IP address should be set as DNS

EG If the router's ip is and your laptop is allocated say then in your laptop's internet connection settings the gateway and DNS should both be set to

Your router WAN settings should be the default IP and DNS that your modem supplies. The router provides the translation to systems on the LAN side. If you set the client PC's DNS to the external setting of your ISP then you are conflicting with the function of the router

Goin' Fishin' (Some day)

Report •

August 2, 2009 at 20:41:40
Ok here are all of the steps to trouble shooting a 2wire modem....

First, never ever run the CD that comes with the modem. It will reset the DSL authentication code in which case you will need to call tech support to get the right code for your ISP's tech support.

Ok now do the following....

- Start button -> Run -> Type CMD
This gets you to a command prompt.

Your results should be something like

Windows IP Configuration

Wireless LAN adapter Wireless Network

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::91e2:13cb:69c6:c29d%13
IPv4 Address. . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

If you get a Media State is disconnected under the Wireless section as well as the ethernet then your WiFi is off.

If your IP Address is 169.254.x.x then the key you have entered for the WEP is not right.

If you have a 192.168.1.X address then you are good.

- Now type PING
You should get a 0% packet loss.
If not then your authentication is not settup properly.
If so then PING YAHOO.COM.
You should get 0% packet loss.
If Not then it can be one of two things.
1) You are connecting to the router but its Firewall is dropping all packets to this computer. If this is the case then go into your MDC and reset the firewall settings back to defaults.
2) You are in the Walled Garden which means you have probably run the CD that came with the modem in which case you will need to call tech support.

- If all pings are successful or if you where able to ping then go to I.E. or Firefox and type the following...
This will get you into the advanced settings of the modem. If it does not come up then there are some problems with your I.E. because if your where able to ping it but nothing comes up then there are security settings that are blocking the page.
While you are in here you might want to double check your firewall and wifi settings.

If you are able to both PING YAHOO.COM with 0% packet loss and to get to the Config page then you should be on. Double check that your home page is not set to a default Intranet insted of an Internet page. Just type in the address bar.

To double check your Authentication settings for the WiFi in Windows XP do the following...
- Start -> Control Panel -> Network Connections
- Right Click the Wireless Connection -> Select Properties
- Click the Wireless tab at the top.
- Then find the your wireless profile in the list. It should be like "2Wire999" or what ever the name of your WAP is.
- Click the properties button.
- Select the Authentication Tab.
- Make sure the Type is "Open".
- Select "WEP" for the Encryption.
- Set the "Security Key" NOT Pass Phrase to the key you setup or the default located on the bottom of the modem on the serial number tag. It is the only number in square brackets like "[12345667789]".
- Hit OK. Now move this Profile to the top of your list. There should be a move up button on the right.
- Click OK.
- Try Right Clicking the WiFi connection chose Disable.
- Right click again and chose Enable.
- Try Browsing.

If this does not work, Call you ISPs tech support. It should be free.

Report •

Ask Question