can no longer nfs mount from mac mini

May 12, 2009 at 03:32:13
Specs: Macintosh 10.4.11
hi! thank you in advance to anyone who can help solve this dilemma! :-)

let me describe my system, and what's up:

system: mac mini, intel core duo chip, 2G ram

network: at&t dsl, dsl modem, linksys router, linksys 10/100 switch, mac mini, debian linux box, readynas NAS box, linksys wireless access point

the previous behavior: i'd log into the mac mini, and mount the readynas using the unix 'mount' command, specifically, i'd use this command:

mount music:/media/Music /music

where music: is the hostname of the readynas.

new, problematic behavior: the mac mini will no longer mount the readynas. i get this message when i try:

mount_nfs: bad MNT RPC: RPC: Timed out

it seems that my "portmap" program is not running. or, if it is, it does not respond to rpcinfo -p. i get:

rpcinfo: can't contact portmapper: RPC: Remote system error - Connection refused

when i try. ps -auwxx does not show any portmap process. starting /usr/sbin/portmap does not seem to change anything - it even says "exiting", as this is the second invocation of portmap. ?

i can mount the readynas from the debian system, so it's not the readynas. and, the mac mini used to mount it, but all of a sudden stopped. i have done no software updates, and my updating is set to manual not automatic.

can anyone help me solve this odd problem? :-)

See More: can no longer nfs mount from mac mini

Report •

May 12, 2009 at 06:18:59
Has the Mac Mini lost all connection ability, for example, the internet? Can you ping the Mac from the Debian box?

How do you know when a politician is lying? His mouth is moving.

Report •

May 12, 2009 at 06:45:13
hi guapo,

thank you for your reply!

the mac mini still has all other connectivity intact. i can get out to the net, do sftp, ping the debian box, anything. i can also ping the mac mini from the debian box - no connection troubles.

the mac just seems to not want to mount anymore - just that one thing! it's very odd. what do you think? :-O


Report •

May 12, 2009 at 14:18:21
Does NAS have a static IP address? If it's DHCP, it may have changed. Check the IP address & try it in the command line instead.

How do you know when a politician is lying? His mouth is moving.

Report •

Related Solutions

May 12, 2009 at 15:18:08
hi guapo,

the readynas has a static IP. i tried mounting by hostname and also IP - same result, with mount_nfs timing out.

someone suggested running "applejack" in single user mode, which i did - it cleaned up a lot of cache files, and repaired permissions. when i try to do a 'mount' now, i do see the portmapper process start up with rpcinfo -p. but, the readynas still fails to mount from the mac (and does mount from the debian box).

i don't get it! as in so many star trek episodes, it should be working, but it isn't. :-) can you think of anything else not yet tried?


Report •

May 12, 2009 at 18:37:33
I just found a lot of hits on Google.
Search for:
mac os x mount nfs

How do you know when a politician is lying? His mouth is moving.

Report •

May 13, 2009 at 02:45:37
thank you for that pointer to google. i checked out many of the entries, but they all (more or less) assume that the 'mount' command works - my basic dilemma is that the 'mount' command all of a sudden just stopped working! i was able to 'mount' the NAS using Finder, but that does not leave me access to the files through a terminal, which is really what i need.

any idea why a command that worked just fine would all of a sudden just stop working? i hoped that removing cache files and a reboot would fix any corrupt data preventing the 'mount' command from running. are there specific files or cache entries that 'mount' leaves on the system which could cause it not to run properly?

Report •

May 13, 2009 at 05:43:21

Try that.

How do you know when a politician is lying? His mouth is moving.

Report •

Ask Question