Belkin N+ wireless router USB storage connection lost

August 27, 2015 at 07:20:23
Specs: Windows 7
I have been trying to connect my external drives to the Belkin N+ wireless router, but no luck yet... I have tried everything i could find on different forums (reboot, reset, update firmware, sharing option of the drive etc.)

The problem I am encountering is that the belkin does not seem to make a connection. The blue 'storage' light on the front of the router does not light up. I have tried two drives and several USB sticks. None of them work. The only time the button lights up, is when the router is reset. It blinks very shortly, and then it is of again.

Has anybody else encountered this? In the past I never had this issue; the router worked perfectly and connected to my old extarnel drive (Iomega.) Now the router won't even connect to this drive....

See More: Belkin N+ wireless router USB storage connection lost

Report •

August 27, 2015 at 08:44:26
Let us have the router model number - it might help in some way.

Always pop back and let us know the outcome - thanks

Report •

August 27, 2015 at 08:44:27
Read the post from _enduroPro_ in this thread:

Report •

August 27, 2015 at 10:08:29

It is a Belkin N Plus wireless router F5D8235-4 v2. I have already tried the solutions mentioned on the microsoft page. Renaming the drive's path for instance. They don't work for me....

Report •
Related Solutions

Ask Question