2 adapters only connect to half of networks

December 5, 2009 at 11:25:24
Specs: Windows XP and Xubuntu
I recently bought a Packard Bell netbook with a built in atheros AR5007EG wireless adapter, and also got a Wisacom USB 200, which uses a Realtek RTL8187 chipset.

When I got the computer the Atheros would connect to the wireless network without problems, but the USB wouldn't. It'd either sit for a minute on 'waiting for network' or 'aquiring network address', then result in 'limited or no connectivity' with some non 192. ip address.

Then I installed Xubuntu and reinstalled XP, and now I have the same problem with the Atheros.

Both adapters are working fine because I warwalked some unsecured networks in the city and they connected to about half of them. The other half got the above errors in Xp, in Xubuntu it's just 'connection failed'.

I've been using some other network utilities and both cards are working fine for those.

Thinking it seems like a DHCP issue, I tried manually setting my IPs, which resulted in very quick connections but no gateway and no connectivity at all.
I've tried uninstalling/reinstalling and updating the drivers etc.

This is really weird. I have no idea what the problem is.

See More: 2 adapters only connect to half of networks

Report •

December 5, 2009 at 16:06:23
The other half got the above errors in Xp, in Xubuntu it's just 'connection failed'

Because you didn't have the security passphrase.

There does not appear to be a problem because you don't mention that you own a router or that you can't connect to it wirelessly.

Report •

December 5, 2009 at 16:33:36
We share our friend's connection, it's WEP encrypted, I have the key. I've tried it with other encrypted and unencrypted networks, all with the same result. Some always work, most always don't.

Report •

December 6, 2009 at 04:35:51
If you can't get connected, it could caused by a MAC address filter configured on the wireless routers.

Report •

Related Solutions

December 6, 2009 at 06:19:05
No, other computers not registered with the network can connect fine.

And like I say, my Atheros worked fine before I reinstalled Xp.

Report •

December 6, 2009 at 06:45:12
Which driver are you using, this one?

Report •

December 6, 2009 at 19:10:31
your device set to support b/g/n wireless? what you describe is a combo of not the right encryption key, right wireless level or you don't have the right drivers loaded for your usb and network hardware.

'limited or no connectivity' with some non 192. ip address.

you would get a 169.254.x.x ip if not connected. 192 means you got a real ip but you apparently can't use it.

Check your FIREWALL software.

Report •

December 7, 2009 at 12:52:26
My atheros drivers are from here:

My current mode is listed as 802.11b/g
I don't know if it's 'n' compatible.

They're defnitely the right keys, I'm pretty sure the drivers are correct and latest, and the networks with which the cards do work, work fine.

I think it was a 169.254, yes.

Windows firewall is off, I don't have any other firewall software installed. Spybot, AVG free, neither walling.

Report •

December 17, 2009 at 11:46:19
No one knows?

Report •

December 17, 2009 at 12:35:19
For general testing purpose, disable encryption and mac address filter on the router.
So you have an open wireless network, that will allow anyone to connect to this wireless network.
When you connect to the open wireless network, you should get ip address, default gateway and dns server ip via DHCP from the wireless router.

Post back, whether is works or not.

Report •

December 17, 2009 at 14:46:49
It doesn't seem to make any difference whether the networks are encrypted or not.

Just checked and I am getting a 192.254.x.x ip on the networks that don't connect. 192.168.x.x on the ones that do.

Report •

December 17, 2009 at 16:37:42
Do you have this connection problem regardless which wireless network adapter is used for that?
Built in atheros AR5007EG wireless adapter or Wisacom USB 200.

Report •

December 18, 2009 at 01:52:11
Now, yes, it seems that way. I can either connect to a network with both or neither.

However before I reinstalled xp and put on xubuntu the network I was using would connect to the internal Atheros, but not the external Realtek.
I was only using the one network at the time tho, I don't know if that was true for others.

Report •

December 27, 2009 at 02:38:50
Looks like this is an especially tricky one.
Whoever solves it gets a medal...

Report •

December 28, 2009 at 14:56:42
If the new xp and xubuntu aren't doing something properly, but the old xp was, then it would suggest there's something I need to set manually, no?

Report •

Ask Question