Novell workstation won't attach to server after moving HD

August 17, 2012 at 16:33:08
Specs: DOS 3.2?, 386
CMOS and possibly m-board died. Gave chksum errors B4. Moved server HD to other
box, gets to boot up normally with new (different) NIC. MONITOR screen shows LAN loaded, IPX bound OK.
W-station won't attach but no error messages. Futzing with server I seem to have created 2 servers, 2 networks
and I seem unable to get rid of one. Re-tried binding LAN to IPX it says net=xxx already in use by another LAN.
Cannot find this to remove it. Does BIOS call for an old IP perhaps, now different on the new motherboard in use?
Changed ports, interrupt#, chkd cabling OK and new PSU's OK.

Any hints appreciated. It's Novell 3.12 from '94 but kept on trucking. Have the commands manual etc. but not
enough IT savvy as I installed it all 18 years ago.


See More: Novell workstation wont attach to server after moving HD

Report •

#1
August 18, 2012 at 11:07:27
Check the startup.ncf and autoexec.ncf file for NIC entries like IPX configuration and bind commands.
Make sure, that only the needed entries are in the autoexec.ncf and that they are not listed twice.
Correct the entries and reboot the server.

Report •

#2
August 19, 2012 at 16:50:39
Thanks you for the hint Paulsep. I was away until now but will try your idea again. It seems an "lconfig over-rides default" shows up on booting but I've been unable to find it's location so far. Will keep you posted. If I recall correctly I checked all the auto- and configs- seemingly for doubled info. On binding IPX to an NIC I often got the "net=xxx bound already" and a prompt for a different net #.

Trying to"clean up" and doing unbinds it seems I miss something. ( Using the same net# as was previous on the net, b4 the crash as I do not want the stations to need reprogramming.)

Did go to collect the original Novell Install discs from my "fixed cache" 150 miles away overnite, in case I need them. It is possible the server was not "downed" gracefully the last time, as I would normally do, and I may need to try a re-install as a fix, but without losing the years of data on it. Is such an approach possible or will it wipe out the existing volumes etc.?

Stay tuned, I'll turn back to the troublesome beast...

Ivoski



Report •

#3
August 19, 2012 at 18:38:54
More info: found the LCONFIG.SYS file and it starts with CFG.. in EDIT mode. Then it mumbles on in ASCII. There are several seeemingly identical lines showing 1-0 in sequence and ABC's in sequence. I'm wondering if this is a junk file? Cannot find where it is called from, neither from autoexec or other -cfg or -bat files.

Report •

Related Solutions

#4
August 19, 2012 at 21:05:56
Long time ago I've managed netware 3.12 server and therefore, it's hard to remember all such things.

When you down the file server, search the nwserver folder for a startup.ncf file and check this file for NIC entries.

It's really long time ago!


Report •

#5
August 19, 2012 at 22:20:07
OK, I hear you about long time ago.

What irks me is I can see info that says the server is up, then I go to another screen to modify say the autoexec.ncf and it claims the vol SYS is not mounted. Similarly when I inserted an old install diskette it claimed to be unable to find the SYS files. I'm beginning to wonder if there indeed is some data corruption on the drive, given the conflicting info.

I did not see any nwserver folder BUT I'll LOOK FOR IT!

Thank you for all your help, it' s good to change horses and gives new ideas.

Ivoski!


Report •

#6
August 20, 2012 at 05:55:10
Volume sys must be mounted.
When it's not, you are most likely missing the correct hdd controller driver program.

Report •

#7
August 20, 2012 at 06:10:07
If you are able to print out the startup.ncf and the autoexec.ncf files, you can try starting the server without loading this files by itself.
Therefore type this command at the DOS command prompt:
server -NS -NA

Then you have to give all commands manually at the nwservers console prompt.
First of all, the content of the startup.ncf and the of the autoexec.ncf file.

So you can check, what goes wrong on that server during boot process.
Write down the errors and google them.


Report •

#8
August 20, 2012 at 07:39:31
When I boot up the server from cold and use the screen breaks there appear to be no errors. It will tell me the correct server name and that vol SYS has been mounted. When I go into the monitor screen it lists the correct HD name/etc and also lists the NIC. Cannot use the more useful SYSCON screen as no w-station is attached yet. An O-scope will show bus activity on the network (BNC-type, terminated in 50 ohm as when it working previously ) This comes from the workstation when I try to attach. When I DOWN the server and it should be notifying stations of the shut-down, there is no bus activity showing on the oscilloscope.

Changed the server NIC card but still NG getting any net-bus life from it. Should I try to verify at least one card as working in another w-station to ensure I have a good card?? Both just MIGHT be bad??


Report •

#9
August 20, 2012 at 09:12:39
Yepp I would suggest to test the NICs first.
It's always good, to have a well know working hardware, when troubleshooting server issues.
Also make sure, that the NICs are supported by Netware 3.12.

Report •

#10
August 20, 2012 at 15:26:26
Hi Paulsep

thank you for all your suggestions and time and trouble. The NIC is not bad, as I exchanged it with a working one which did transmit data onto the bus. I tried a re-install of the server but am unsure if I have the correct diskette for this. Screen calls for a _INSTALL disc, I only have a SYSTEM_1 disc with a serial # and 3 copies of it. I think they are functional equivalents.

I was able to bring up USER names on one screen but if I try to copy a xxx.NCF to SYS it won't let me, saying it's not installed. At other times I get info that SYS has been mounted. Wondering if there is some library corruption. ( got a "could not find CLIB" at one point. )

When I ran the INSTALL.exe from a:drive I finally did get my single server (DISPLAY SERVER) AND SINGLE NETWORK too. That was some progress, but it did not bind IPX to the NIC. "protocol not loaded"

Later I got a "VOL SYS not found in installation list"

Is there a relatively inexpensive way to recover this SYS volume, as there may not be much wrong in the bindery/library? Drive repair firms likely charge a fortune and I'll only get the data on CD's perhaps. That alone doesn't really help me much.. An analytical repair/sleuth program may be more the ticket for this. What do you think should be my next steps?

Ivoski


Report •

#11
August 20, 2012 at 19:08:44
The amount of disks of the complete netware 3.12 is 25 floppy disks.
If you only have 1 disk, you can't reinstall netware.

What's about the vrepair command at the netware console, to repair netware volumes?


Report •

#12
August 20, 2012 at 19:24:40
Thanks Paulsep, I'll see if Vrepair does anything later, if it's on there. Sure hope it does.

I do not recall that many discs (25) but perhaps I loaded off a CD drive originally.
There sure is no D drive in the server at present and server.exe was only about
550kl. Stay tuned.


Report •

#13
August 21, 2012 at 11:01:58
Paulsep

not much luck with vrepair. Sometimes I now get a "hardware not found" message when I try to reconfig the NIC. At another time a console had me logged into my print_server screen, instead of the main server. ( some gremlin from the NIC card that I had "borrowed" from that station??) did I

Anyway, I'll need to give up on this drive now unless I can find someone to copy it over to a new one with some recovery software or suchlike. Any suggestions on this?

Thank you for all your help and support !

Ivoski


Report •

#14
August 21, 2012 at 12:25:00
What about using another (if possible old) computer, to setup a new netware server on it?
When installation is completed, down the file server, attach the drive in question, start the file server and mount the volume (if possible).

Report •

#15
August 21, 2012 at 12:51:35
Not quite sure if I follow you on this but get the hardware idea OK. I'd have two drives in one box on the presumably same network #. My difficulty seems to be having master/slave drives and dealing with one through DOS, the other via Novell.

Right now I am unable to consistently get to vol SYS. It will tell me it's loaded but when I actually want to get something off/on it there are the "not loaded" or can't find messages. It's like a partial load to satisfy a few parameters but obviously not the whole shebang.

As there is no workstation attached yet some of the Novell commands are unavailable to me, but might become so with configuring "the new server". That would be a big help, definitely. Have to explore this a bit but right now my existing back-up server also has some issues with logging onto it. I'm also running out of boxes soon...

Ivoski


Report •

#16
August 21, 2012 at 18:20:58
I start losing the track a bit about that.

Hopefully, the hard drive in question, especially the netware partition, is untouched by any kind of software tool, to restore the volume!

If so, I strongly suggest to make an image of the whole hard drive with e.g. Norton Ghost, TrueImage or something like that.

When having such an image, you have thousends of attempts and can always restore the original state of the hard drive.

You may also try installing Netware 3.12 onto a virtual machine, add an additional virtual hard drive, where you can restore e.g. the ghost image and check, whether you can access the data of the virtual drive for doing a backup (which generally should have been done in the past !!!).


Report •

#17
August 21, 2012 at 20:16:44
Good ideas Paulsep. Myself, I have not quite all the know-how how to do that but I'll certainly pass your ideas on to someone who has. Both my youngsters are in IT but do not have much of a clue dealing with my rosetta stone system. Nor does Fry's or Radio shack sell those nifty flint adzes any more to chip away at these problems.

Until I can locate someone to help me with this hands-on I'll need to let it slide and go to plan B, which will be to adapt the old DOS to run virtually on a more modern but single-user station. That really is all I require right now. Obviously, I'll have to restore at least some of the current data.

Thanks again and I'll keep you posted on any news.

Ivoskis


Report •

#18
August 22, 2012 at 09:07:20
If the only problem at the moment is, to install good old DOS on to another PCs hard drive, you only need to have the DOS disks, boot from the first disk, create a small partition, reboot, format the newly created partition with the DOS format command and install DOS onto it.
The original DOS disks will ask for installation at boot time.

Report •

#19
August 22, 2012 at 09:15:34
Thanks Paul

I'll have one or even both of my youngsters over on the weekend. As a "time-capsule" we might go launch DOS on another box. Getting another and similar server running is perhaps a good idea, as then the disk drives can talk to each other without the NIC card. That communication link really seems to be the biggest obstacle at this point.

Ivoski


Report •

Ask Question