where can i download old versions of adaptec

April 17, 2011 at 20:32:41
Specs: Macintosh
I have a Power Mac 7600 running OS 7.5.5. Been using Adaptec Toast 3.5 & Jam 2.5.
Just bought an old Yamaha 8824 cd burner. My Toast & Jam won't read this burner.
I read somewhere that I need to upgrade my Toast to v4.0.2.
Is this correct?
Where can I find this version?
Is this version supported by OS 7.5.5?
What version of Jam do I need?
Any other issues I need to be aware of? I may have to just return this cd burner.

Thank you so much, Howard


See More: where can i download old versions of adaptec

Report •

#1
April 18, 2011 at 00:49:18
I'm not sure on the upgrade information, however, I'll still be able to find what you need for your Mac:

Toast 4 is available on eBay right now, and it is pretty cheap. You can click here to see the results page: Toast 4 search results.

Also, Toast 4's requirements were/are System 7.5. However, I have not heard of Jam. You have a Power Macintosh 7600, which I believe was capable of Mac OS 8, if not even better, 9.0. Can you upgrade your system up to 8 or 9? I believe that starting with 8.6, Macintosh software allowed people to begin burning discs with the Finder. With Mac OS 9, you can run iTunes, which further can enhance this experience. Newer versions of Mac OS are very compatible with older applications written for System 7.

I hope all this helps you get things to work--let me know if you have any other questions or comments. It's been a pleasure assisting you. :)


Report •
Related Solutions


Ask Question