volume keys on MAC keyboard not working

February 1, 2011 at 09:36:09
Specs: Macintosh OS X
my MAC keyboard (wireless) has the volume buttons at F10,11 & 12..Nothing happens when I press them.. Can't control the volume there anymore...?? why?

See More: volume keys on MAC keyboard not working

Report •

#1
February 2, 2011 at 23:12:29
Check in System Preferences, in the Keyboard & Mouse preference pane. To find this, go to the Apple menu in the menubar that runs across the top of the screen. Click "System Preferences..." and click "Keyboard & Mouse" under the Hardware category. Check in the Keyboard and Keyboard Shortcut tabs to see if the keys are either turned off or aren't mapped to work with the volume anymore.

Report •

#2
February 3, 2011 at 04:54:26
i tried all the option there before...somehow all th FUNCTION (f) keys are not doing what they are supposed to. The option listed Keybrd/Mouse for settings only lead me to the microphone and internal speakers.. Any other ideas? Any sugggestions would help- I am a new MAC user so all this stuff is FOREIGN to me! lol

Report •

#3
February 3, 2011 at 18:57:51
By the description given, are you using an eMac? These models map the function keys differently than other models.

In the Keyboard pane of Keyboard & Mouse, is the option "Use all F1, F2, etc. keys as standard function keys" unchecked? (This option may not appear, as from the description of the F11 and F12 keys, you are not using an Apple notebook.)

Secondly, can you remember the last thing that happened before your keys quit working? Did you set anything from any other application or did you get a faded out screen with a black box in the middle, saying "You need to restart your computer..." in five languages? (The last event I mentioned is referred to as a 'kernel panic'.

Thirdly, did you go to Sound? The options you mentioned match that of the Input and Output tabs of the Sound preference pane.

Thank you for replying so far. I'm simply trying to get to the bottom of this issue. :)


Report •

Related Solutions

#4
February 4, 2011 at 08:59:54
I did try the checked box for the F1,F2 etc .. i checked it and tried the buttons, and did the opposite, and nothing! and nowhere on the keyboard list is there anything for volume.
I dont' remember what happened before because my husband was the one on the computer and he asked me why they volume button wasn't working so I have no idea what happened! but I don't this that box with the message came out because he would have asked me..lol
But NONE of the F keys are doing anything! none of the functions work. The brightness,volume, mute etc. Thanks for your persistence! I appreciate it!

Report •

#5
February 4, 2011 at 13:40:53
It appears you have an eMac or an early iMac from your keyboard's description. To get a better answer, please indicate if you are running an eMac, iMac G3, G4, or G5.

To help you determine this, the iMac G5 and Intel stand up completely flat, and are one unit with the flatscreen. The G4 sits on "half an Apple core" or sphere, and has a screen attached to an arm. The G3 looks like a large rounded computer, and the eMac looks similar to the early iMacs, except that it is pure white, and NOT transparent like the iMac G3 Snow.

However, to flush the computer's memory, and to try and coerce the keyboard into working again, turn your computer off (In the menubar spanning the top of the screen, open the Apple menu, and click Shut Down. Click Shut Down again in the dialog box that appears.) When you are done, unplug the keyboard from the USB port, unplug the computer, and hold the power button for 15 seconds. Plug the computer and keyboard back in.

Turn the computer on, and before you hear the first chime, hold down Cmd+Opt+P+R. This is a keyboard hotkey, which will reset the parameter RAM. Cmd is the command key, indicated by a four-leaf clover loop. Hold that combination down, if you have a G3/G4/G5 until you hear the Mac chime four times.

Try booting up, and see if the suggestion provided fixes the problem. Also, in another post, you had mentioned the screen on the same computer (I'm assuming) being messed up. Has this problem been fixed as well?


Report •

Ask Question