Unable to Format USB Flash drive

Apple 13.3" macbook pro notebook compute...
March 10, 2019 at 12:50:08
Specs: Mac OS Mojave 10.14.3, 3.1 GHz Intel Core i5, 8Gb LPDDR3
I compressed my Photo Library on my MacBook Pro (with Mojave) and was copying Photo Library.zip file onto SanDisk Ultra 128GB Dual Drive USB Type-C flash drive. Disk has exFAT format. While copying something happened and now my drive is readonly. I cannot copy anything to it or delete any files from this flash drive.
I tried Mac Disk Utility to format using Erase option but it said Operation Failed.
Then I tried NTFS for Mac. I used verify command in it which said cluster chain of Photo Library.zip has too many clusters for its size. The volume couldn’t be verified completely.
I tried Windows 10 to format still it threw error saying disk is read only.
I tried diskpart command however clean command fails for this disk. I tried tools like EaseUS, IOMEI Partition Manager however both apps said it is readonly volume. I am not been able to use this USB flash drive. Please help me I need flash drive to be formatted to MSDOS 32 format.

See More: Unable to Format USB Flash drive

Report •

#1
March 10, 2019 at 17:24:34
It may be that the usb stick is faulty., for whatever reason. How old is the drive?

When you right close ck on the desktop con for the drive, then view “info”... what are the access permission showing at the bottom of the info pane?

Also is the drive locked?

Incidentally I have a Kingston 64Gib flash drive/usb stick, brand new and bought a few years ago. Never been out of its shrink wrapped cardboard until this evening.. Tried to format it to Mac - wouldn’t work, drive inaccessible etc. messages. Tried to format it to fat32 - same problem

Tried reformat in win-7 - failed there too.

Sometimes these not so reliable devices are just that...?


Report •

#2
March 10, 2019 at 20:11:26
trvlr thanks for the answer. Drive is brand new. Just a month old. I am able to read files on this drive from both Mac and Win. I know partially copied Photo Library.zip on this drive is the culprit. However I am not able to deleted it on both Mac and Win. Is there a way using Terminal to delete this file along with all other content of the disk? That might solve the issue?
Verify and subsequent repair option on NTFS for Mac showed "The bitmap needs to be repaired" "The volume ABC could not be verified completely." are the error msgs.

Below are the results of First Aid and Erase Options in Disk Utility

First Aid result —
Running First Aid on “MyPenDrive” (disk2s1)

Repairing file system.
Volume was successfully unmounted.
Performing fsck_exfat -y -x /dev/rdisk2s1
Checking volume.
Checking main boot region.
Checking system files.
Volume name is MyPenDrive.
Checking uppercase translation table.
Checking file system hierarchy.
Cluster chain for /Photos Library.zip has too many clusters for its size.
Checking active bitmap.
The volume MyPenDrive could not be verified completely.
File system check exit code is 1.
Restoring the original state found as mounted.

Erase Result —
Erasing “MyPenDrive” (disk2s1) and creating “MyPenDrive”

Unmounting disk
Couldn’t modify partition map.

Operation failed…

message edited by seema_kat27f


Report •

#3
March 11, 2019 at 05:08:30
My situation is more or less the same I think; other than that the flash drive is new out of its shrink wrap and never been used. I am trying to format it to fat32 - but getting the problem that my Mac (el capitan) doesn't recognise it; yet it shows up in disk utility.

I tried disk utility to no avail;

Then found this amongst many similar hits via google; which I tried and still no joy... The drive cannot be opened!

Perhaps it will work for you?

https://apple.stackexchange.com/que...

Be "very" careful to note the device you're addressing; likely it will shown as an external... Again Read the instructions very carefully...


Report •

Related Solutions

#4
March 12, 2019 at 07:56:39
I purchased a couple of Toshiba 64Gig (and one 32Gig) flash drives/memory sticks. Installed into my MacMini and it was fine...

This tends to confirm the y Kingston 64Gig is toast... As everything I've tried thus far won't resurrect it.

Sadly I suspect your Sandisk is likewise duff. As it's under warranty(?) perhaps conatct vendor (even Sandisk...?) and see what they come up with?

If they replace it as, be aware that some of your photos may still be on it; is that OK with you?


Report •

#5
March 15, 2019 at 02:50:35
re’#5

I tested that method with my never used 64Gig Kingston stick.

Disk utility couldn’t access it, or than to run the first aid option, after which disk utility couldn’t do anything further.

Win-7 disk manager equally couldn’t do anything with it either, it could see it a partioned drive but not able to do anything to or with it.


Report •

#6
March 16, 2019 at 09:15:26
trvlr ad dmcnair thanks for your answers however these pointers didn't troubleshoot my issue. Luckily SanDisk was courteous enough to give me replacement of the drive as it was under warranty even though I have lost the receipt as a proof of purchase.

message edited by seema_kat27f


Report •

Ask Question