My mac can't find a printer

September 6, 2013 at 05:41:30
Specs: Macintosh
I have "rebooted" wireless printer, checked password. It is hooked up. My mac book can't find the printer and it won't let me type it in on that screen. What's up?

See More: My mac cant find a printer

Report •

#1
September 8, 2013 at 03:58:32
Has that printer ever worked with your MacBook?
Have you installed that printer's Macintosh driver on your MacBook?

Note: If the printer manufacturer has no Macintosh driver for that printer model, then the printer must be compatible with "Apple Airprint" otherwise it won't work with your MacBook.

The official list of Airprint-compatible printers is here:
http://support.apple.com/kb/HT4356

message edited by phil22


Report •

#2
September 8, 2013 at 07:02:33
Yes it did work but after a long period of not using it, I tried to print and it said not connected. So I right clicked and got rid of the printer. Then when I am trying to add another printer that printer not only doesn't show up, but the computer won't let me type anything in, like it is frozen. Am I understanding that I need to find the disk from the printer and load it into my mac again?

Report •

#3
September 8, 2013 at 07:03:20
by the way, I did reboot and reenter my password for WIFI and the printer says hooked up.

Report •
Related Solutions


Ask Question