mac unable to support architecture

March 30, 2011 at 03:30:39
Specs: Macintosh
downloaded both skype and logitech and unable to open either - just the above message keeps popping up! Help! Have no knowledge of computers so need a very basic and easy resolution - please! :)

See More: mac unable to support architecture

Report •

#1
March 30, 2011 at 04:22:41
Are you downloading OS X versions of these programs? You won't get Windows versions to work on a Mac.

Report •

#2
March 30, 2011 at 15:12:13
yes am downloading the mac os version

Report •

#3
March 30, 2011 at 23:53:40
What model is the Mac and what version of the Operating System is it running?

Report •

Related Solutions

#4
April 1, 2011 at 12:22:33
I also would like to assist you, but ijack is right. We need to know your model (if you are not sure if you have an Intel or not) and what OS you are running.

- To find this out, if you are confused, click About This Mac from the Apple menu in the very top, left corner of the screen. You will notice whether it will say Mac OS X 10.4.11 or something, and whether it will say G4, for instance. This is all that you will need to tell us--and we'll tell you if the package can be installed or not on your system.

Thank you.


Report •

#5
April 1, 2011 at 13:53:43
Ok - It is a MAC os x 10.5.8 G5.
thanks

Report •

#6
April 2, 2011 at 00:55:47
The latest version of Skype doesn't support PPC Macs, which explains your problem. You need to use an older version; try: http://www.skype.com/intl/en-us/get...

The same is probably true for your other software. Look for versions that support PPC hardware, not just Intel.


Report •

#7
April 2, 2011 at 01:02:26
thanks people! Will give it a go! Have installed it on the pc but really wanted it all on the mac!

Report •

Ask Question