Solved MAC goes to sleep after ~30mins, and then won't stay on.

November 2, 2015 at 20:36:23
Specs: OS X, Power PC G4/2GB
I have a Power MAC G4, dual 1.25GHZ, 2GB DDR SDRAM, with Max OS X 10.4.11. The machine will power up for about 30 to 45mins, then it instantly drops into some kind of standby or sleep mode. The display goes blank and the power lights on the monitor and box start pulsing slowly. By pulsing I mean they dim and brighten. If I push the power button, then the machine instantly comes alive again. And after only 1 or 2mins, it drops out again. This gives me enough time to tell it to shutdown. And then after some indeterminate amount of time, I can power it back up but the problem just keeps repeating giving me only 30 or 45mins to do anything. What is causing this and how do I fix it?

Edit:
This mac I'm reviving also prompted me that it's system time was set to before 2001 on boot up. It was set to 1969. I think this is a separate issue, but the original owner doesn't remember much about it. I am assuming that is a CMOS battery issue.

Also, it looks like the CD/DVD drive is not being seen by the OS. I'm not familiar with MAC, so I had trouble just seeing how to tell it to open the tray. I forced it to open by restarting and holding down the mouse as it boot. I put a DVD in the tray and tried to use the burn folder, but it just asks for a disc. So, it seems like at a hardware level the DVD drive is working but I can't tell if it is working in the OS. I clicked on something called iDisk, but it said its not there. Am I doing this right?

Edit:
Well, we figured out you use the keyboard to open the drive, and it's looking like it may just be a CD drive.

message edited by ISAmad


See More: MAC goes to sleep after ~30mins, and then wont stay on.

Report •

#1
November 3, 2015 at 01:25:30
Well, I ran AHT (apple hardware test) Version 1.2.6. Both the quick and extended tests report the same thing.

AirPort: No Device Found
Logic Board: Passed
Mass Storage: Passed
Memory: Passed
Modem: Device Found
Video RAM: Passed

As far as the CMOS? issue. I get no warning like you would on a PC before the system boots. It actually doesn't show me anything on bootup. The popup appears after the OS loads.

As far as the DVD drive, it looks like you can't see the device until you have a valid disc in the drive, then an icon appears on the desktop. And I looked at the specs, it takes DVD-R discs. I was trying it with DVD+R discs. So, all seems fine with that.

Here are the specs, mine is the M8573LL/A.
https://support.apple.com/kb/SP63?v...

While booted to the OS, I just experience it not only going into a sleep/standby mode, but a failed attempt at it and then a recover. Something like a brown out.

message edited by ISAmad


Report •

#2
November 3, 2015 at 02:37:41
✔ Best Answer
If you have moved past the CMOS battery issue....

Have you considered temperatures?


Report •

#3
November 3, 2015 at 22:57:38
I opened the machine up and measured the PRAM battery, its 0.96V.

I'm looking into how to get into the PRAM settings screen to record some things just in case. Anyone know?

It'll probably just be factory default, but I have run in to it on PC where the voltage was too low to keep the clock but was still maintaining other settings. On Dell for instance I found it wiped the service tag number afterwards. Also, it's not a coin cell so I'll have to wait before I can get one anyway.

And I am looking into monitoring the temperature. I was hoping there was a way to monitor it within OS X, but I haven't found it. So I did a google search and I found an app called iStat version 3.19 by Bjango. Have you used it or have another suggestion?

https://bjango.com/mac/istatmenus/v...

I haven't installed it yet. I downloaded it on my windows 7 machine and looked inside the zip file, but don't recognize the file types. What is an executable in a MAC environment? Or better yet, how do you install an app on a MAC?


Report •

Related Solutions

#4
November 5, 2015 at 17:58:30
Well, it is sounding like there is no BIOS on a MAC. Or what could be called BIOS is called firmware or EFI. And that it can be edited at a command line, but has no CMOS PC style GUI. So I am not sure what to do but replace the battery and hope its fine.

I found the console within spotlight and the system.log file.

It shows "power-mac-g4 kernel [0]: Power Management received emergency overtemp signal. Going to sleep."

Edit: Something else odd as well.
"power-mac-g4 VersionCueCS2Daemon[124]: warning: versionCueCS2Daemon not started by mach_init process (parent pid: 1)

Edit: iStats V3.19 won't work on OS X 10.4. Looking for another option.

message edited by ISAmad


Report •

#5
November 7, 2015 at 16:16:47
It looks like the primary cause of this was that the CPU fan was not plugged in.

The machine was reportedly never serviced around the time that this started happening, but I find it hard to believe the fan could have been unplugged all this time.

The wire pair from the fan to the connector is short and it makes a tight 180 turn where they come together on the logic board at the board edge near the hinge on the chassis door beneath the secondary hard drive cabling. It has a key/clip to keep it in place, but I could see if that was never properly connected that it might have come loose on its own.

I could go on, but it has now run for an hour with no overtemp failure, hopefully it continues to do so and there are no after effects.

message edited by ISAmad


Report •

Ask Question