emac (no DVD) update from 10.3.9 to 10.4

August 8, 2011 at 12:16:24
Specs: Macintosh
new programs need minimum OS 10.4.11, current OS 10.3.9

See More: emac (no DVD) update from 10.3.9 to 10.4

Report •

#1
August 9, 2011 at 11:01:31
You need to purchase a copy of 10.4

http://computers.shop.ebay.com/Oper...

If your Mac has the speed and RAM I would skip 10.4 and go straight to 10.5

http://computers.shop.ebay.com/Oper...

iMac G5 1.8GHz "Hero" PowerPC
2 x 1GB DDR PC3200 SDRAM
160GB WDC WD1600JD-40GBB2
Mac OS X Leopard Version 10.5.8

http://sdfox7.com


Report •
Related Solutions


Ask Question