Cannot delete old backups

August 9, 2012 at 09:55:38
Specs: Macintosh
I have used Time machine for some time. I have a 1Tb external disk for this, which is partitioned in two 500 Mb parts. Time machine is now about to fill one partition soon, and I tried to delete old backups, but to my horror the deleted folders are stuck in the trash can. I cannot empty the trash can at all. Why???? I need to empty the trash can, but how to I do it? And how can I delete old backups? I have tried to turn off Time Machine before deleting, but it does not help either.
Machine: iMac w/8Gb RAM, Core i5, Lion 10.7.4, 500Gb disk, 21inch, bought Oct. 2011

Kaare Nilsen
Norway

edited by moderator: remove personal information


See More: Cannot delete old backups

Report •

#1
August 16, 2012 at 08:12:59
Have you checked to see what permissions were assigned to the files you are trying to delete? They may be either locked, or the account you are signed in with does not have administrator privileges. Here is an article from apple that may be helpful..

http://support.apple.com/kb/HT1526


Report •

#2
August 17, 2012 at 00:27:02
I am the sole user and as such the administrator of my Mac, so your solution is not the one.

Report •
Related Solutions


Ask Question