USB Mouse stops working after starting Debian

Acer Aspire 7540-1317 notebook - athlon...
September 13, 2010 at 10:56:25
Specs: Windows 7 Professional, 32-bit, Debian 5.0 Lenny 32-bit, Ubuntu 10.04 LTS triple boot, 2.0 GHz, 3.00 GB RAM
I have a major problem with my USB mouse. I have a dual boot of Windows 7 and Debian Lenny, with Linux kernel 2.6.26. It is newly installed as of today and it is using Gnome desktop environment. The problem is that when I start the computer, boot into Debian, Linux starts up, shows the graphic login prompt and I log into the system and I am on the desktop. My Dell USB mouse stops working after a short time, it will freeze and I cannot move it. I cannot scroll or click on anything, the cursor just stops dead. I have googled this problem numerous times and have not got anywhere. Is there a file which logs USB device errors in Linux? I am reasonably new to it but I guess I am comfortable using basic terminal instructions. I am using 3 USB devices, a Microsoft natural ergonomic keyboard 4000 a Dell USB standard mouse and Dell USB speakers. This version of Debian Linux is newly installed from a CD in a dual boot.

See More: USB Mouse stops working after starting Debian

Report •

#1
September 13, 2010 at 15:44:16
Not sure where to tell you to start. Xorg has logs and /var does.

I guess you could try to unplug and plug it in to see if it returns.

I'd begin to think it may be the usb speakers doing this. I guess you could remove them and see if that is part of the cause.

Seems kind of an old kernel too. Dunno about that.


Usually bios legacy issue falls off once the OS takes over so I don't suggest you fool with that but it could be some bios settings.

Could be a current deal on the usb hub but I doubt that.

Why did it take me over a year to phone in a problem to ATT?


Report •

#2
September 14, 2010 at 16:51:22
You should also check the output of the dmesg command; this can tell you if the module is crashing, if the mouse is detected as being unplugged, etc...

Report •

#3
September 18, 2010 at 09:58:07
I checked dmesg, it showed nothing strange or any error messages. I tried unplugging and replugging the damn mouse, it still did not work, still stopped working. I tried rebooting, unplugging the speakers seemed to work for a while but since then I have installed Ubuntu on the machine, because I had trouble installing graphic drivers. Ubuntu works fine with all the USB devices.

Report •
Related Solutions


Ask Question