Ubuntu graphics driver not working?

Dell / DIMENSION 2400
January 22, 2012 at 14:01:14
Specs: Ubuntu 11.10, 2.657 GHz / 1GB
I have a fresh copy of Ubuntu 11.10 installed on my Dell Dimension 2400. everything on the machine is stock except I upgraded memory to 1GB and have a radeon HD 2400 pro graphics card

it is running really choppy. youtube videos skip a lot, it looks like they play at only 5 fps. even at 360p.
also, dragging windows around on the desktop seems very laggy/choppy (it takes a few moments for the windows position to 'catch up' after moving it). loading programs or doing anything graphical on Ubuntu seems to take longer than it should. scrolling down a webpage with the middle mouse button seems to lag a lot.

I installed the proprietary driver from System Settings > Additional Drivers. it was labeled: 'ATI/AMD proprietary FGLRX graphics driver'
after restarting, it says it is activated and currently in use, though the system seems to not be any different, it might even be slightly worse than before.

I had Windows XP installed very recently on this same machine only a few days ago, and it didn't have problems like this at all. it ran smoothly and could play youtube videos up to 480p without being choppy at all, and programs weren't laggy/choppy. dragging windows across the desktop seemed very smooth.

I am an Ubuntu newbie, so I'm not sure what to do. I am thinking maybe the graphics driver isn't installed/activated correctly?
does Ubuntu 11.10 use up a lot of resources? if so, maybe my RAM is too low to run this OS smoothly.
at the login screen, I chose to use "Ubuntu 2d" instead of the default, but the problem persists.

any advice/help for me would be appreciated. I will check this thread periodically


See More: Ubuntu graphics driver not working?

January 22, 2012 at 14:07:39
Dump Ubuntu 11, install Mint 12.

"Linux Mint is an Ubuntu-based distribution whose goal is to provide a more complete out-of-the-box experience by including browser plugins, media codecs, support for DVD playback, Java and other components. It also adds a custom desktop and menus, several unique configuration tools, and a web-based package installation interface. Linux Mint is compatible with Ubuntu software repositories."


Report •

January 22, 2012 at 14:11:11
You need to install the Linux ATi Driver:


Report •

January 22, 2012 at 14:50:22
@Jolicloud that page just tells you to install the ATI proprietary driver, which I've already tried doing, if you read my original post..

@riider I will consider doing that. I will put that option on the backburner for now. I want to see if I will be able to fix this first, on Ubuntu. if not, I guess I will move on to Mint 12 and see what that has to offer


Report •

Related Solutions

January 22, 2012 at 15:59:03
Is there still an internal video card/chip? Remove the HD.

Is this a rambus model?

Katy Perry, I'd never treat you badly.

Report •

January 22, 2012 at 18:01:48
there is no other graphics card plugged in. besides my Radeon 2400 card, there is only intergrated graphics.

I don't know what rambus is, do they make memory sticks? my memory was bought from Crucial.com, and my HD is Western Digital.

would this really be a hardware problem, though? since this machine worked perfectly under Windows XP and ran smoothly. do you think there might be a compatibility issue with my hardware and Ubuntu?


Report •

January 23, 2012 at 03:33:20

Otherwise remove the Radeon HD 2400 Pro Graphics Card and only use the Integrated Intel Graphics, please post back results....

Report •

Ask Question