SBC ATT/Firefox connect problem

March 3, 2009 at 07:05:48
Specs: Ubundu 8.10, dual core 2
Okay guys I really need some help on this one. I have a new desktop which I have installed Ubuntu 8.10 on. I have setup the internet connection as per the directions and it is showing me online in theTerminal. That’s as good as it gets however, I then open Firefox and try to go to a web page and get redirected to ATT yahoo’s page telling me my browser is not supported. So I did some research and found that some have gone through Firefox via an IP address to get to SBC’s register page. When I do this I get through the Member’s agreement page to the Member identification page where I have tried to use “my” Member ID and Password and also the Member ID: and Password: sbcyahooreg that some of the successful Ubuntuians have used. After posting either of these ID’s and passwords I try to click the NEXT button in the lower right corner but nothing happens. I do get a highlighted button when I place my cursor over it however. Note I cannot get to these pages via the or any other IR address I look up. I have to use the URLs to get access.

The next problem/problems are directly related to the first. Although I am entirely new the Linux world I’ve found (correct me if I am wrong) “everything” revolves around having an internet connection. I have spent six days trying to manually install packets, other browsers, and patches, (opera, user_agent, ies4linux, etc), all in an effort to resolve my connection problem. Obviously none of these efforts have worked and the only thing I can now do with Ubuntu on my new computer is play the game programs. I am hoping if I can get by the registration setup I will be able to then have full internet access. Any of you guys care to help this newby out? Thanks

Go to in your web browser
Enter the following login information:
Member ID:
Password: sbcyahooreg

Member agreement page:
Member identification page:

See More: SBC ATT/Firefox connect problem

Report •

March 3, 2009 at 09:06:30
Does this computer connect directly to the att broadband modem or do you connect to a router which is in turn connected to the att modem?

One possibility (if connected directly to the att modem) is that you need to connect using a pppoe (point-to-point-protocol-over-ethernet) connection. pppoe uses your att user name and password in its configuration when connecting to the att service.

If on the other hand, you have a router connected to the att modem, your computer should connect to the router using a standard LAN (ethernet) connection since the router handles the pppoe
connection for your entire LAN (it acts as
your LAN's gateway to the Internet).

If you have more than one computer connected
directly to the att modem you should check that the modem is designed to connect more than one computer to the Internet. If the modem has one ethernet port (looks like a big phone jack) and one USB port, it is designed to connect one single computer to the Internet. You can use either the ethernet port or the USB port, but NOT both at the
same time. To connect more than one computer to the att modem, you will need a router (connect your computers to the router, then connect the router to the att modem. Configure the computers to connect to the router using a standard network (LAN) connection. Configure the router to connect to the att modem using pppoe.

These are the hardware issues of which I am aware. If none of these apply, then you may have to check with your att customer service to make sure your user ID and password are correct (they will usually be case sensitive - 3b1a4 is not the same as 3B1a4 or 3biA4). They will not support Linux (shame on them), but they should be willing to help you confirm your configuration information. I use a cable connection here because I do not like DSL or ADSL because it requires the additional complexity of pppoe configuration, so I can not be of much help with configuring the att service. Good luck,

Ernie Registered Linux User 247790

Report •

March 3, 2009 at 14:23:47
thanks for the reply Ernie.
your first example is my situation, one computer with direct modem connection (no router). pppoe more than likely has nothing to do with my problem as my laptop (winXP) connects just fine via the direct modem hookup. Plus terminal also shows me online when I check it. from what i have discovered the Firefox browser supplied with 8.10 is where my problem more than likely hides. i've found that ATT does not support this browser for registering and since i'm getting the ATT unsupported browser page every time i open Firefox it just may be the problem.

I’ve also found others that have had this problem who have used a fix for Firefox called user_agent which changes the agent ident of Firefox to either IE or Opera (Opera can do this on it’s own too). I did try this however the latest edition of Firefox is not supported by this fix, imagine that! I’ve also tried installing Opera but like I said I cannot get anything to load in this copy of Ubundu. My fear is I will have to buy another stinking copy of XP and install it over Ubuntu and then use IE to register my account. I do know that will work as it is just what I did with my laptop. Now on that computer I can use any other browser I want.

Bottom line ATT in their infinite wisdom requires every user to use IE to register their accounts in order to get online no matter which operation system they are using. Like I said unless I can find an “off-line” fix to the Firefox supplied by Ubuntu or am able to install a browser that will identify itself as Internet Explorer I will have to add to Bill Gates retirement fund… again. Kinda the reason I came over to the Linux side of the road to begin with.
Thanks again

Report •

Related Solutions

Ask Question