(Re-)booting problem

September 13, 2010 at 07:00:52
Specs: Linux i686, Pentium M/2GB
Hi,

After several days investigating I gave up :-)

Hardware: Thinkpad R40 with 160GB Samsung Spinpoint (PATA), XP Prof SP3 on primary, XUbuntu 10.04 on lba partition. The 160GB HDD is a replacement for the original 40GB. The "Hidden Protected Area" of the Thinkpad was cloned from the previous to the new disk.

fdisk -ul yields

Device Boot Start End Blocks Id System
/dev/sda1 * 2 4741 35841897 7 HPFS/NTFS
/dev/sda2 4742 20260 117316080 f Extended LBA
Warning: Partition 2 does not end on cylinder boundary.
/dev/sda5 4742 6111 10349640 b FAT32
Warning: Partition 5 does not end on cylinder boundary.
/dev/sda6 6112 6376 1995840 82 Linux swap
Warning: Partition 6 does not end on cylinder boundary.
/dev/sda7 6376 6641 2003400 83 Linux
Warning: Partition 7 does not end on cylinder boundary.
/dev/sda8 6641 10516 29295000 83 Linux
Warning: Partition 8 does not end on cylinder boundary.
/dev/sda9 10516 20260 73664640 83 Linux
Warning: Partition 9 does not end on cylinder boundary.


* Booting XUbuntu 10.04 with GRUB into linux works.
* It also boots correctly into windows.
* When I do nothing else in windows, then I can reboot with GRUB.
* However, editing one image with Photoshop CS4 and then reboot makes GRUB disappear -
until I have re-installed GRUB with the XUbuntu CD. There is no error message, just a black screen and reboot. This repeats to infinity.


What I did already:

1. Checked RAM, HDD, and the Computer extensively with PC-doctor
2. Dumped the MBR before and after the issue, but I could not find any differences in the dumped output. I did that with "dd" from linux, and with "MBRWiz" in linux.
3. Tried Dualboot (NTLDR) with XP's default MBR (using the dumped MBR with GRUB). With that configuration, Same behavior: If I do not use Photoshop, then fine. Using PS makes GRUB disappear upon rebooting (i.e., selecting linux option in NTLDR yields black screen and reboot). At least windows remains bootable then.
4. In Windows, after working with PS (to produce the error) and before rebooting, restored the MBR with MBRWiz. No effect, GRUB disappeared.
5. Tried to reproduce the issue with my old 40GB HDD with analogous partition of the HDD. With the old HDD, everything works fine (However, due to space limitations, I did not install any windows update on the old HDD). That is, I can do PS and reboot and GRUB remains there.

So, using windows and doing PS seems to change something on the Hardisk.

Doe anybody know a workaround for that? Any ideas what windows could do to cause GRUB disappear?



See More: (Re-)booting problem

Report •

#1
September 13, 2010 at 13:00:57
Wonder if you have a partition issue such as overlapping partitions? Might use ranish to see.

Otherwise I'd have no idea why ps would damage grub unless it is some virus deal or ps is hacked or maybe scratch disks are in wrong place.

Why did it take me over a year to phone in a problem to ATT?


Report •

#2
September 13, 2010 at 16:39:59
Thanks for replying. A virus in my XP is unlikely...but in the meanwhile I did a further experiment and installed lilo. Upon lilo -v it complains that the partition table is not consistent, so I use the option "ignore-table" in /etc/lilo.conf. Still, on windows, i have NTLDR installed, with GRUB. Now there comes the funny thing. I boot into windows, provoke the issue, and reboot. Foruntately, lilo is still there, and boots correctly into linux and windows! Now, when booting into windows, and selecting "linux" from NTLDR (where GRUB appeared before), I get again a reboot without GRUB showing up.

Is seems definitively to be related to GRUB. While googling I found on the web information that some windows programs seem to write license code between the end of the MBR and the 1st sector of the 1st partition (GRUB does use this space also??? --> phase 1.5?), and this could explain the mess (ADOBE, what did you do...?).

But this is just a hypothesis, I am not a specialist on MBR and such, nor on hiding license code.


Report •
Related Solutions


Ask Question