Reboot, init, and shutdown command not found

October 6, 2010 at 12:42:54
Specs: openSUSE 11.3 x64, 4 Intel i5 at 2.53 GZ and 4GB of ram
I use the 11.3 openSUSE distro on my laptop. These commands worked fine when I first started using it but after a bit they starting coming back that I may need root privileges. So I would sudo it and it replies command not found. I cnf the commands and it says they are present. the commands work in su, but I want them to work normally again... Help please...

See More: Reboot, init, and shutdown command not found

Report •

#1
October 6, 2010 at 13:03:28
Thats because /sbin folder is not in set in the $PATH variable.

The original poster should always write the last response !!!
Let us know, if the problem is solved !!!


Report •

#2
October 6, 2010 at 13:24:04
How would I set it there?

Report •

#3
October 7, 2010 at 13:03:33
It really depends on how you are using sudo. If you are executing something like:

su root

it should ask you for your password, but it still uses your PATH. If that doesn't work, add the sbin to your PATH:

# Untested
export PATH=$PATH:/sbin

You also might execute:

su - root

You become root using root's environment and not your own.

And, of couse, you can always use the full path:

/sbin/<your command>


Report •
Related Solutions


Ask Question