Partition table is invalid

January 30, 2011 at 03:22:09
Specs: Kubuntu 10.10 32bit, 2.16Ghz CPU/2GB Ram
Hello, my partition table is broken, but Kubuntu boot up.
I had with 3 NTFS Volumes and 1 extended with two Linux: swap and ext4 root.
Windows is on second NTFS volume, third is my Data drive(But windows is not working too -- thats another story).So I wanted to repair it, but nothing worked. I left it for now. But C: drive have 74 GB of free space.
Using KDE Partition Manager, I have tried to shrink my NTFS second volume (disk C:).
Suddenly, it started lagging, so i shut it off with killalll -s KILL. Next time when I rebooted my laptop NTFS(first and second) partitions was gone. I boot off from Live CD and run TestDisk to recover them.
After that fdisk begun saying that first NTFS partition not ends on a track boundary. I have deleted it (It was TOSHIBA SYSTEM VOLUME, but I have two dvd's to restore). System is working now, but all partitioning utilities is not working. They want to create new partition table.

My fdisk output:
/dev/sda2 192 22676 180602724+ 7 HPFS/NTFS
/dev/sda3 23950 26822 23069248+ 7 HPFS/NTFS
/dev/sda4 26822 30402 28756948+ f W95 Ext'd (LBA)
/dev/sda5 26822 30341 28262400 83 Linux
/dev/sda6 30341 30402 487416 82 Linux swap / Solaris
What I have to do?

Sorry for my English.


See More: Partition table is invalid

Report •

#1
January 30, 2011 at 09:43:27
Well, I can say you are in a pinch.

There is no good way to fix this. I have used ranish to fix this before but you may end up loosing data.

It can also be that there is no problem and you fixing it will only make it worse.

Backup all data before you go any farther and test that data if you can. Then simply delete all partitions and start over.

I have not seen this issue for a while. It was a problem with some old linux and other fdisk that seems to have caused it. I can't say why it happened now.

I'd also test disk and memory to be sure.

"The era of big government is over," said Clinton 1996


Report •

#2
January 31, 2011 at 02:22:58
I've had this problem occur occasionally. Partition not ending on a track boundary. This occurred on new computers with factory installed OS that I was attempting to repartition. I think it is caused by factory cloning software on drives that may have bad sectors. I found the only dependable way to fix the partition table is to copy the partitions to another drive then zero fill, partition, format and copy data or reinstall software.

Report •

#3
January 31, 2011 at 08:26:21
Thanks, I can try that next time, when I reinstall the OS. But now Linux its working, and I want to simply mkfs -t ext4 my C: drive. Of course with data backup.

Report •

Related Solutions

#4
March 27, 2011 at 07:00:24
After 2 months i managed to fix it.
My extended partition was too big, so gparted cant find any partitions.
I used sfdisk and fixed it to normal size using live CD.
Now i am in openSUSE 11.4:)))

Report •

Ask Question