Linux Mint Display Not Loading On Install

January 23, 2010 at 12:39:50
Specs: Windows 7 Home Premium, Athlon 64 3gb
Hi guys,
I don't know if you've tried to use Windows 7 Home Premium, but it's awful. I was trying to install the newest Linux Mint on my laptop today and encountered a problem. I put the CD in and rebooted. I can see the two lines of text indicating that the LiveCD of LinuxMint is booting, then the screen goes black. Typically, this would be when you see the green Linux Mint background display while it loads. If I wait for about 5 minutes I can even hear the Linux Mint startup sound, so I know it is loading.

Any advice for what to do about the display? My other computers use Linux Mint, so I'm fairly comfortable with that at this point.

System:
Windows 7 Home Premium 64-bit 6.1 Build 7600
Dell Laptop
Inspiron 1764
Bios: ver 1.00 BIO A01 Parttbl
Processor: Intel Core i5, m 430 @ 2.27GHz (4 cpus), ~2.3GHz
Memory: 4096 mb ram
Graphics: Intel Graphics Media Accelerator HD


Thanks in advance.


See More: Linux Mint Display Not Loading On Install

Report •

#1
January 23, 2010 at 14:53:35
A few ideas.

Dunno how mature the 64 bit version is might also try the 32 bit disk.


Try the disk on another system and on boot splash countdown press space bar for options. Might as well run the disk check and maybe even the memtest.

If passes then try I think it says vesa or failsafe choice try it.

See this http://www.thinkwiki.org/wiki/Intel...

With a system like that, I'd run a virtual machine. The laptop is fully capable of using VM's at or above native speeds. Get Vmplayer 3 and load it up.

Playing to the angels
Les Paul (1915-2009)


Report •

#2
January 24, 2010 at 10:44:12
Thanks so much Jefro. I had neglected to mention that I could also see the 10 second count down before the load. I was not aware that you could hit spacebar and then make a selection. I selected Compatibility Mode and everything was fine.

Thanks a million! Goodbye Windows, hello OpenSource!


Report •

#3
February 9, 2010 at 07:37:28
Hi, I bought a 1764 from BB this past weekend, hoping to
create a dual boot win7/fedora machine out of it, and used
the win7 disk utility to free up space in D:

The fedora live installation CD would load but quickly become
stuck wit a black black screen, similarly with the fedora dvd.
After reading the current thread I tried both media, pressing
the space bar repeatedly with no luck.

Opensuse faired better, it installed grub but not a working
linux system. I tried restoring win7 using the disk image
on the hard drive with no luck. I guess I'll have to try
reinstalling the operating system from the CDs provided
by dell. Is linux having trouble with the display or
graphics card?

Monkeybut, I would very much appreciate hearing more
about your i1764/linux experience and if anyone else has
suggestions or pointers I would be grateful in hearing
those as well.

-M


Report •

Related Solutions

#4
February 9, 2010 at 08:47:49
I'm no expert, so this will be very novice advice:
In LinuxMint when you would put the install disk in and booted the computer, a green bubble-y background would appear and would say "LinuxMint will load in 10 seconds". During those 10 seconds, I hit spacebar and then selected to load into compatibility mode.

I did a quick search and wasn't able to pull up any information about how to boot fedora into compatibility mode though.


Report •

#5
February 9, 2010 at 11:42:13
Hi Monkeybut, thank you for the quick reply. When you
run LinuxMint on your 1764 does everything work
(full screen resolution, wireless, sound, etc.)?

I also looked for a mention of someone installing fredora
on an i1764 with no luck. I guess the hardware is too
new to be supported. Yikes!

-M


Report •

#6
February 9, 2010 at 11:58:58
The only complaint is that LinuxMint was only able to run at 1024x768. I searched and searched and could not find a version of the firmware out just yet. Though I did find a build they are working on at http://intellinuxgraphics.org/ but it was a bit over my head at the moment. I check back periodically now for when the firmware is released.

Report •

#7
February 10, 2010 at 16:01:02
Hi Monkeybut, I guess I'm in the same boat and will have
to wait until linux catches up with the i1764's hardware!

Report •

#8
March 29, 2010 at 07:59:03
Just got Ubuntu to install on my new Dell 1764. Had to fiddle with the function keys to get the installer into the "Safe Graphics Mode". I had the same Black Screen Experience as Munkybut. I'll add updates when the install finishes and I start using the mochine.

Tried Win 7. Toooooooo Slooooooow!


Report •

#9
March 29, 2010 at 09:15:51
Ubuntu 9.10 AMD64 came up fine, but no luck so far with the Wireless drivers. Also, several of the keyboard-candy (mouse lock, etc) isn't functional either. Well, looks like this mOchine is going back to Wal-mart (Wally World) if they'll take it.

Otherwise, I'll be stuck waiting for the Linux Train to catch up to the H/W.

=== Update:
Wireless works at home, but not at work. Not sure why. It did work when I had Win 7 installed. Not a big issue for me now. Starting to work with the machine and produce e-mails, OO docs, and found my way on YouTube after installing Java Script and Adobe Flash from the Ubuntu Software Center on 9.10

Curious how 10.04 will do on this laptop.

Looks like this laptop is a keeper.

Running it against Win 7 ... It screams !!!


Report •

#10
April 2, 2010 at 16:52:32
Captain's last log: LOL
Wireless quit working at home, and can't get it to work until Windows 7 was loaded back on it.

Pulled the back cover off, found the WLAN card and found it is not listed on any of the Linux Drivers websites.

Returned Dell to Wal-mart.

"Dude!, you're not getting a Dell !!!"


Report •

#11
April 30, 2010 at 11:21:02
For anyone still looking into this: Ubuntu 10.04 now supports my display. Considering Mint is built on Ubuntu, I'm assuming the next big update they do will add support.

Report •

#12
May 19, 2010 at 21:53:24
Linux Mint 9 has come out and it now fully supports my display. :) The wait was worth it!

Report •

#13
May 27, 2010 at 20:39:27
How about wireless? Does it work out of the box?

Report •

#14
May 28, 2010 at 10:12:12
Sadly, the wireless requires proprietary drivers. On the upside, Mint finds it immediately and you just need a working wired connection to install them. So, as long as you're not strictly building an open machine, you can get wireless working.

Report •

Ask Question