How to fix Perl

April 12, 2011 at 18:23:56
Specs: CentOS
I am having an issue with Perl when I try to install programs such as Shorewall:

error: failed dependencies:
perl(Scalar::Util) is needed by shorewall-4.4.18-0base

We are using the latest version of Webmin with CentOS 2. I would like to upgrade the OS, but the rules of the competition are that we are not allowed to use a CD and we do not have physical access to the machine.

I am hoping that a linux guru knows the command to fix this, because the competition is on April 29.

Thanks in advance.


See More: How to fix Perl

Report •

#1
April 12, 2011 at 19:31:58
Your version of perl does not have the Scalar::Util module:

http://search.cpan.org/~gbarr/Scala...

You should be able to download it from CPAN.


Report •

#2
April 12, 2011 at 20:07:16
How do I install it? I'm not very familiar with the command line interface, that's why I use webmin.


Report •

#3
April 12, 2011 at 20:16:17
Do the rules say you can ask us for help? :) hehehe

1/3 of highway deaths are caused by drunks. The rest are by people who can't drive any better than a drunk.


Report •

Related Solutions

#4
April 12, 2011 at 20:47:07
From the link I posted, look off to the right; you'll see a download button. If that doesn't do it for you, then you are on your own as I am not a real cpan.org guy. Check out this link for more help:

http://perl.about.com/od/packagesmo...


Report •

#5
April 13, 2011 at 17:37:51
I followed the entire article from Nails, but it still gives me the same error message.

And yes, we are allowed to ask for help. ;)


Report •

Ask Question