Solved Grub rescue after uninstall Ubuntu 12.11 From W8

February 5, 2013 at 22:19:51
Specs: Ubuntu 12.11 x64, i7 2630QM/8GB
Hello. Today when I found out wubi is a gigantic disaster I decided to get rid of it and get a real Ubuntu installation. These are the specs before everything went to s---:

Windows 8 x64 dual booting w/ wubi Ubuntu 12.10 x64 by Windows boot loader

So this is what basically happened:

Installed Ubuntu 12.10 x64 from flash drive livecd (where I am atm), configured it etc
Grub working to boot Ubuntu and Windows 8/wubi
Copied important files I had on wubi inst back to W8
Tried running wubi-uninstall.exe -fail
Tried removing by appwiz -fail
Got ownership of the wubi partition (success), then tried the above again -fail
Tried this* and also failed (which is probably the causer of all this)
Only then tried this** which is what actually "worked"
grub rescue>

What Gparted tells me
Gparted says ubuntu part is using only 6gb so thats probably screwed, then theres that weird unknown fs
New Ubuntu install doesn`t have much in it, but formatting W8 isn`t an option.
So what can I do now?

just copied to wubi folder and ran it
bcdedit /delete <GUID from wubi partition>
delete wubi partition

See More: Grub rescue after uninstall Ubuntu 12.11 From W8

✔ Best Answer
February 18, 2013 at 05:19:02
Time-wise, is it worth it? If a learning expderience is desired, yes; practically speaking where only a fix is desired, no. FYI, this link may be useful --

February 5, 2013 at 22:36:52
Sorry, I meant Ubuntu 12.10, can someone fix the title for me?

Report •

February 9, 2013 at 11:21:22
this may allow you to get back into windows:

"but formatting W8 isn`t an option."

whenever you "mess" with the partitions on a drive that already has an OS on it you risk losing the OS, if thats not an option , don't do it.


Report •

February 10, 2013 at 14:02:49
Hey, thanks for the reply, I already worked this out and forgot about the thread hehe
So if anyone ever has the same problem here`s what I did:

Booted from UbuntuSecureRemix DVD
Updated everything
Ran Boot-repair with default settings
And everything got fixed

Only problem is that I have 2 W8 entries on GRUB, but I can live with that.

Report •

Related Solutions

February 10, 2013 at 14:23:56
So when looking at the generated file I came across this and I`m just wondering if it`s something to worry about:

Windows not detected by os-prober on sda2.
Warning: extended partition does not start at a cylinder boundary.
DOS and Linux will interpret the contents differently.

Also this, since I already deleted the wubi partition:

A broken Wubi has been detected. Please fix it this way:

Report •

February 12, 2013 at 05:24:34
Wipe the HDD & start over.

Report •

February 13, 2013 at 13:16:02
Such a useful reply...

Report •

February 14, 2013 at 22:58:48
Are you happy with the way things are working out? How many hours or days have you spent trying to fix what you screwed up? Sometimes you need to know when to give up & start over from scratch. If you don't like my suggestion, that's fine, no one says you have follow any advice that I or any of the forum helpers provide.

Report •

February 16, 2013 at 20:36:54
Yes I`m happy with it, but as I said I`m not sure what the 'cylinder boundary' message means, if one OS will be writing information over each other or what.
Yes I spent quite some time, I was just following official instructions on the ubuntu wiki, so if there`s any screw up it`s on their part.
If I were to start from scratch I`d have already done so.
What I don`t like is when someone replies with the 'last measure' without even caring to explain why should I give up.

Report •

February 18, 2013 at 05:19:02
✔ Best Answer
Time-wise, is it worth it? If a learning expderience is desired, yes; practically speaking where only a fix is desired, no. FYI, this link may be useful --

Report •

March 9, 2013 at 15:25:13
Teacher of this subject told me it's nothing to worry about.
Thanks for the link fish, it has good info.

Report •

Ask Question