Google Earth/F15 no imagery in application

June 20, 2011 at 19:03:47
Specs: Fedora15Linux-x86_64, i7-2600/8GB
.After installing Google Earth under Fedora 15 x86_64, the application opens (both from the applications page and when invoked from a terminal), BUT there is no imagery - just a black screen in the middle. I can shift to Google Maps and that works and displays correctly, but it is almost as if the imagery is not making through from the server. The system has an nVidia GTX 460 video card and a Sandy Bridge processor and nVidia proprietary drivers. Gnome 3 works Why no imagery, when the rest of the application seems to work correctly?

See More: Google Earth/F15 no imagery in application

Report •

#1
June 20, 2011 at 19:51:07
Do you need flash installed?

1/3 of highway deaths are caused by drunks. The rest are by people who can't drive any better than a drunk.


Report •

#2
June 21, 2011 at 06:29:35
Try starting in DirectX mode. Start Menu>All Programs>Google Earth>Start in Directx mode

I had that problem also.


Report •

#3
June 21, 2011 at 07:05:04
Many thanks for the suggestions, I will go ahead and install flash (which I had been avoiding for several security related reasons).

I will also explore the idea of DirectX mode, particularly since you had the same problem, but your fix is for a Windows environment and I'm using Linux, specifically Fedora 15 with the new Gnome 3 and Gnome Shell.

Other than this rather odd problem with Google Earth and a minor glitch with HD sound, everything else seems to be working quite well


Report •

Related Solutions

#4
June 21, 2011 at 18:49:24
"Start Menu>All Programs>Google Earth>Start "

That makes me think it won't work in linux.

1/3 of highway deaths are caused by drunks. The rest are by people who can't drive any better than a drunk.


Report •

#5
June 22, 2011 at 19:40:15
Well, installed Flash, made sure I had the most recent version of the nVidia drivers, did an update of installed packages and while everything else seems to work (even HD sound), I have the same problem with Google Earth. Application starts, brings up splash, and opens the app window with a black screen no imagery. Even the tip window pop up works, but nothing in the imagery window. Any other ideas?

Report •

#6
June 24, 2011 at 11:51:40
Well, it turns out that neither flash nor DirectX were the answer. Apparently the Google Earth application is at least in part 32 bit code, thus 32 bit libraries need to be installed in Fedora 15 for it to work. Once the libraries were installed, "it just worked"

Report •

#7
August 9, 2011 at 08:39:34
What libraries did you install? I have exactly the same issue!

Report •

#8
August 9, 2011 at 16:16:59
I used yum to install the base 32bit libraries, once installed, Google Earth "just worked". Hope this helps

Report •

Ask Question