Solved Disable UEFI Instructions for Asus B450M-A Linux

June 19, 2020 at 22:55:23
Specs: Linux x86_64)
I will be building a system with Asus B450M-A MB with a RYZEN 1200 processor. The OS will be either Ubuntu or Linux Mint.

I understand that I will need to disable secure boot. Anyone who has done it with this MB and installed Linux, please provide the exact settings to make a Linux install work.

TIA

message edited by fherman


See More: Disable UEFI Instructions for Asus B450M-A Linux

Reply ↓  Report •

#1
June 20, 2020 at 08:14:01
✔ Best Answer

Reply ↓  Report •

#2
June 20, 2020 at 10:27:31
Thank you.
I'm waiting for the MB to arrive. I will post my results when I have it.

Reply ↓  Report •

#3
June 20, 2020 at 10:35:30
BTW, I recommend Mint over Ubuntu. Mint is based on Ubuntu but more user friendly. I prefer the Xfce edition rather than Mate or Cinnamon, but that's your call. Go with 19.3 for now, 20 is still in beta testing. Once 20 goes mainstream, you'll have the option to upgrade in place.
https://www.linuxmint.com/

Reply ↓  Report •

Related Solutions

#4
June 20, 2020 at 10:49:05
Yes, I use Mint on other workstations and servers here. And yes, I use Xfce because it is much more efficient than Cinnamon for our workstations that do heavy graphics.

Reply ↓  Report •

#5
June 24, 2020 at 16:15:26
I was able to install Mint 19 Asus B450M-A by disabling UEFI mostly following the instructions in the above link.

However, the bios on my MB did not have a simple Clear Secure Boot keys option. Instead it just listed a number of keys. I tried the first one, and when the Mint installation got to the point of writing grub boot on the hard drive, it failed.

I then went back and just erased all the keys, switched back to Other OS, and then rebooted and did the install. That worked perfectly.


Reply ↓  Report •

Ask Question