Xp420 keeps saying replace black cartridge

November 14, 2017 at 17:28:09
Specs: Android
Replaced black cartridge and it still says replace cartridge. Tried another cartridge in case the first one was bad. Still no luck. These are Epson cartridges and not some generic ones.

See More: Xp420 keeps saying replace black cartridge

Reply ↓  Report •

#1
November 14, 2017 at 20:01:09
Have you inserted the right cartridge model/number for that printer?

Reply ↓  Report •

#2
November 14, 2017 at 21:40:34
I one had an Epson printer and once in a while a bit of ink leaked out and got on the electrical contacts where the cartridge contacts the printer. Use rubbing alcohol and Q-Tips to clean the contacts on both the cartridge and the printer back behind the cartridge. This should work to get the cartridge to be read correctly.

You have to be a little bit crazy to keep you from going insane.


Reply ↓  Report •

#3
November 16, 2017 at 15:29:50
What is the exact message you are seeing? I have an Epson WF7620 which has 4 cartridges. I am using Generic cartridges and I get a message that tells me I am not using Epson genuine cartridges. If I click on "proceed" it will accept the cartridge. However, not every brand of generic acts the same way. Some act like the cartridge is empty.

What is the printer model?


Reply ↓  Report •
Related Solutions


Ask Question