xcopy killed my hard drive? (SOLVED)

October 14, 2010 at 15:35:28
Specs: Windows XP Home SP2
Hey, I'm having a serious problem with my hard drive - it appears that all the data is gone. All I done was run "xcopy c:\folder1 d: /E /H /K /O" and since then, that hard drive "D:" is "Access Denied" when I try to access it. File System shows as "RAW", and used/free space is 0. FOr some reason, my system restore points are all gone today. I have updated antivirus software. And reformatting is a last resort as it has 20GB of data I'd like to get back somehow. Thanks in advance...

See More: xcopy killed my hard drive? (SOLVED)

Report •


#1
October 14, 2010 at 17:27:28
Kind of doubt xcopy did it unless you made a small typo originally.

Might try ultimate boot cd maybe. It has testdisk and photorec.

Why did it take me over a year to phone in a problem to ATT?


Report •

#2
October 14, 2010 at 19:32:20
I used testdisk and it said that the main and backup boot sectors are identical... this would mean that the problem isn't the BS? I would have testdisk rebuild it but I want to be sure first. Also, it was able to list my files, proving that they're still there.

Report •

#3
October 14, 2010 at 19:56:10
Also, chkdsk runs fine and scans the whole drive. Could it be an XP permissions problem or something?

Report •

Related Solutions

#4
October 14, 2010 at 20:39:28
I have fixed the problem. For anybody's reference, the problem was xcopy's /O tag messed up the ACL info for the drive. Used 'cacls' command from the command line "cacls d: /E /G username:F" and gained access to the hard drive again.

Report •


Ask Question