Wrong RAM Frying Dell Dimensions 3000 mobo and hard drive?

August 20, 2013 at 13:59:21
Specs: Windows 7
Hi guys. I sat on my laptop screen and since its a few years old i dont think its worth the cost of fixing it even though it is running great.

I went to a local recycle place to get rid of an old TV and saw a dell dimensions 3000 and took it home with me along with a monitor. They were glad to get rid of them.
Fired it up and worked great. Except only had 256mb of ram so i needed more.

My brother had an old pc in his atttic i asked him to drop it up to take the ram out.
I installed the ram and apparently fried my mobo doing so!!!

So then I thought of just taking the HD out of my fried pc and putting it into is
as I wanted to keep files and fried that as well as I connected it while the power was on.

Well I had a spare hd so I connected it and had a dell windows 7 cd lying round and installed it.

Is it common to fry mobos by simply instaling a stick of RAM?? The 1GB is in now but I'm afraid to add the 256mb one.

I dont believe I have a sound card can someone help me determine if I don't?

Windows 7 is saying 3 days left to register. I have windows 7 on my bbroken laptop but the key won't work. Will i not be able to use windows 7 after some days? I only want a pc for online poker, surfing the internet.

message edited by maca1214

See More: Wrong RAM Frying Dell Dimensions 3000 mobo and hard drive?

Report •

August 20, 2013 at 15:14:09
You must remove the battery and the AC power BEFORE inserting RAM. Are you sure the RAM was the correct type. Some look similar but do not have the correct number of contacts. Inserting the wrong RAM will cause damage.

Your post is confusing. Is the Dimension 3000 still working or not?

Isn't there a key on the running laptop?

Report •

August 20, 2013 at 15:31:51
The dell is going back to the recycle. I fried it installing the RAM. I'm using my bros pc now that he built himself. I can't find what sound card i have or if i even have one.
the key on my windows 7 laptop will not work on the windows 7 dell cd.
note; my laptop was not a dell, that cd was just laying around.

Report •

August 20, 2013 at 16:12:09
Virtually all motherboard made in the last 10 years have integrated sound.

Unless the board is really new, Windows should have installed the sound chip drivers.

If you look at the motherboard printed circuit board, you should find a model number and version printed on the PCB. Post it here for driver help.

Report •

Related Solutions

August 20, 2013 at 17:23:06
I cant see it, is there any other ways>


Report •

August 20, 2013 at 17:48:57
That information might show on the posting screen when you first turn on the computer or in cmos/bios setup or you can download some system info software like everest:


(It's the download link on the right.) Or Belarc:


You might want to tone down your 'shoot first and ask questions later' approach to computer upgrading. You'll ruin less hardware if you slow down and do a little research first.

Report •

August 20, 2013 at 18:23:46
Like OtheHill said, your post is confusing. You're all over the place talking about different systems. And no offense but it doesn't appear you have a lot of experience.

According to Dell, the Dimension 3000 uses DDR RAM, either DDR333 (PC2700) or DDR400 (PC3200), 1GB max per slot. SDR, DDR2, & DDR3 RAM are all notched differently & do not fit in a DDR slot unless they are forced & forced hard. Same goes for installing the RAM backwards, you would have to force the crap out of it to get the retainers on the end of the slot to snap in place. If you forced the wrong RAM in place (or the right RAM but backwards) & then tried to fire up the system, my guess is the memory controller fried. And since the controller is integrated into the motherboard, the board is fried.


I guess the sound problem is with your brother's PC? To get it to work, you need to confirm that it's enabled in the BIOS, then you need to install the sound drivers. But to download the drivers (assuming you don't have the drivers disc) you need to know which sound chip is on the motherboard. To be able to help, we'd need to know the make/model/model number of the board you're working with.

Report •

August 20, 2013 at 19:21:49
gs7610 ultra is the mobo. audio is enabled in bios.
device id Field Value
Device Properties
Device Description Multimedia Audio Controller [NoDB]
Bus / Device / Function 32 / 1 / 1
Device ID 1039-7012
Subsystem ID 1019-1880
Revision A0

is that any use?

message edited by maca1214

Report •

August 20, 2013 at 19:46:11
sis 7012
according to driver genius. but apparently not supported by windows 7.
so i guess im sol

message edited by maca1214

Report •

August 20, 2013 at 20:37:47
Here's a link to the motherboard page:


It shows the sound chip as:

º ADI AD1888 6-channel audio CODEC
º Compliant with AC'97 2.3 specification

Which OS are you running? Win7? ECS lists no Vista or Win7 sound drivers but the following ones might work:


Report •

August 20, 2013 at 22:39:33
The first one didnt work. Whats interestung hough is the guy here http://www.techsupportforum.com/for...
had the exact same problem with exactly the exact same specs to a T.
So i installed the codec the guy recommended and the speaker volume bounces up and down when i play a song but get no audio exactly like that guy after he installled the codec. But his final post then says his problem is fixed in the next post and doesn't explain how when asked by the guys that helped him.

Report •

August 21, 2013 at 00:55:06
Google showed a lot of hits for 'AD1888@SiS7012' I'm not sure where that's coming from but I guess that's where you're getting the SiS7012. Seems like it'd be one or the other. But yeah, it looks like there's no win 7 drivers for either. I checked Intel's site and their download for the AD1888 only went up to vista and I couldn't find anything at all on Analog Devices' site (they make the AD1888)

That's an older chipset that was aroiund when win 7 came out so it's possible win 7 has those drivers built in. And when drivers are built in you often won't find a separate download for them. Have you done an 'update driver' search from device manager? Seems like windows would have set it up on the initial installation if it had the drivers but it won't hurt to give it a try.

message edited by DAVEINCAPS

Report •

August 21, 2013 at 05:11:16
Hi guys. I asked my brother to give me the HDD that was oringinally in it as the sound worked. I assumed it was XP but it is windows 7 on it too afterall. I switched hard drives and still get no sound in his widows 7 install. I checked the driver and it the same one I installed last night on the hd i took out.
(the one recommened in the link in my last post).

If I go to control panel and configure speakers to stereo and run test I get no sound from the left and right speakers.
However if I set it to quadrophonic or 5.1 surround, I get sound only from the RR and RL speakers as he tests each one individually.

Report •

August 21, 2013 at 05:43:43
Many times the manufacturer doesn't list drivers IF the device is supported by the operating system. Windows may support the chip but you have the speakers connected wrong, or one of the MANY sound settings is set to mute.

Do you see a speaker icon in the tray by the clock?

In control panel, do you see a Sound listing?

Report •

August 21, 2013 at 05:48:02
Ok, I plugged the speaker jack into the rear green speaker port as opposed to the front and the sound is now working.
Thanks for you help evryone for trying to help.
out of curiosuty, if anyone would like to explain why my set up can only use the green jack for stereo I'd like to hear it.

Actually I imagine if I plug in two more speakers into the front speaker port I could have quadrophonic sound.

Either way probl;em solved.

message edited by maca1214

Report •

August 21, 2013 at 11:42:15
The speaker configuration determines how you hook up. I have stereo speakers with a subwoofer. I feed the sup and the sup feeds the speakers. That is by design. So I connect to line out.

Something else to note. When dealing with HD sound, the jacks are programmable so you MUST actually click on the jack you connect to in the software in order for it to work.

Report •

Ask Question