write delayed failed issue with Seagate 1.5TB external HDD

March 18, 2012 at 11:08:51
Specs: Windows XP sp3
Hello folks,
Hoping someone can help that may have had this issue before.
Upon googling it sure seems to be a common issue.

I have an external hard drive seagate external 1.5 tb that is giving me the following issues.

delayed write failed. Windows was unable to save all the data for the file
E: |Mft. The data has been lost. This error may be caused by failure of
tyour computer hardware or network connection. Please try to save the file
And in event viewer: " An error was
> detected on \device\harddisk1\D during a paging operation"

I'm running win xp.It happened during a transfer of some files
Sometimes i am able to open the drive and view the files but i can't move anything to save it.
I've tried CHKDSK but it says it cannot get access to the volume.
Tried testdisk 6.13,easeus,hhd regenerator, but when they tried to gain access to the "g" drive it gives the "write delayed failed" message.

I ran seagate drive diagnostics and it tells me it needs service but try to recover your data, it is under warranty so i can't dismantle it.
At this moment i have the folder open and am writing everything down that i can all 187 gb's worth.

If anyone out there knows the answer or any suggestions i would be very grateful.

I just tried to move some files but i get an error message "cannot copy path is too deep.

Thank you.

See More: write delayed failed issue with Seagate 1.5TB external HDD

Report •

March 18, 2012 at 13:15:10
Your external hard drive MUST be plugged into a USB port that can actually supply 500 ma of current. It may NOT be detected or work properly if you have it plugged into a USB port in an external USB hub or on the front of your desktop case.

Troubleshooting USB device problems including for flash drives, external drives, external memory card readers.

See Response 1:

Report •

March 18, 2012 at 13:36:41
Do you always use the "Safely Remove" icon when disconnecting the external? Data may still be in the buffer or in Windows memory when you disconnect it without using that icon.

See the link below concerning the path to long message.


Why are you using FAT32 on a 1.5TB drive? If you need FAT32 for compatibility then partition the drive into MANY partitions.

Report •

March 18, 2012 at 14:40:36
The drive is ntfs and plugged in usb in the back.
Everything was fine until a few days ago when windows crashed as i was transferring.
I've tried a few usb cables.
I do use the safely remove icon.

How does one go about removing data fromthe buffer or memory?

Thanks again.

Report •

Related Solutions

March 18, 2012 at 15:26:06
If the system crashed then the data and directory was corrupted. The cached data was lost. The copy and delete method is preferred over moving for transferring files.

Report •

March 18, 2012 at 18:53:48
If the computer is yours, you should always keep a copy on the computer as well as the external hard drive, unless there is not enough room on it's drive. Then you need to make other arrangements for backing up the files. You should never keep only one copy of important files, they should always be on more than one drive. If your computer is short of space, consider adding another internal hard drive or replacing it with a larger drive. then you can use the external drive for your back ups and for portability when needed.
Then you could just repartition and format the drive if it is salvageable, or replace it if it is not and copy the files back to it from their source files.

You have to be a little bit crazy to keep you from going insane.

Report •

March 18, 2012 at 20:03:07
Windows – Delayed Write Failed – Solved!

"I bought a 500 GB Western Digital My Book Premium external hard drive. For few days, everything was working fine, but suddenly the Delayed Wrifte Failed error started to pop up and my drive was no more accessible. Here’s the error displayed on Windows:

“Windows – Delayed Write Failed : Windows was unable to save all the data for the file X:\$Mft. The data has been lost."

There's more there, mostly about this error with internal hard drives

Page 2 - his solution that worked

His newest solution - probably the best one.

Report •

March 19, 2012 at 09:44:42
Thanks for all the suggestions everyone.
So far no luck but i am following and doing all the help.
If and when this works again i will post back the soluton.
Sometimes the drive opens and i can look at all my files, there all there but that's as far as i have been able to get to.

Much Appreciated. Please keep the suggestions coming.

Report •

March 19, 2012 at 10:23:26
This may not have anything to do with my problem external but when i run ccleaner with the external on it hangs at empty recycle bin 40% until i shutdown the external.

Could it be a corrupted recycle bin on the external?
Just wondering.

Thank you.

Report •

March 19, 2012 at 10:31:23
CCLeaner will NOT fix your problem !

See response 6, especially the last solution !

Report •

March 20, 2012 at 08:24:13
Using that info in response 6, you should be able to fix your Write Delay Failed problem, but you may still have data damage. .

If you do fix that problem, then test the drive with Seagate's SeaTools for Windows - do the long test.

If SeaTools finds nothing wrong with the drive itself, any or most data errors found can probably be fixed one way or another.

Report •

March 20, 2012 at 09:48:50
Thanks for all the help it is much appreciated.
I actaully didn't expect ccleaner to do anything i was just wondering why it stopped "emptying recycle bin" and if there was a connection.

I will try the info in response 6.
I will post my progress when i have some.

Sometimes the drive opens up enough i can see all the files but that is the end of it.

Also the external sometimes shows the folders as empty but shows the entire drive the correct 187 gb.

Thanks again.

Report •

March 20, 2012 at 12:42:08
When the external drive is plugged in and you're getting the Write Delay Failed problem when you try to access it, any program that tries to access files or folders on the external hard drive can have problems. There are normally hidden $Recycle.Bin and Recycler, or Recycle Bin.bin and Recycler, folders on every hard drive partition.

"Also the external sometimes shows the folders as empty but shows the entire drive the correct 187 gb."

Whatever you see or don't see should always be the same.

See the info in response 1 !


For some desktop mboards you can have problems when an external hard drive is plugged into one of a pair of USB ports on the back of the case that are connected to the same USB controller, if there is another device plugged into the other USB port for the pair, because the pair can't actually supply 500 ma per port - they can only supply 500 ma in total. Usually those pairs of ports are one above the other, not beside each other. If you have two devices plugged into such a pair of ports, try plugging one of them in elsewhere on the back of the computer.

If your hard drive inside the external enclosure is ~ 200 gb manufacturer's (decimal) size, the computer's bios and the operating system see the total drive space as it's binary size, 1,073,741,824 bytes per binary gb = ~ 186.26 gb (binary) .
If you have one partition on that drive space, the size of that partition that can be used for data is a bit smaller - ~ 186.26 gb minus the space taken up by the software partitioning (NTFS or FAT32 or FAT) and the formatting, and minus ~ 8 mb of unallocated drive space Windows reserves at the end of the drive space.

When you hold your cursor over the hard drive partition's drive letter in My Computer or Windows Explorer, Or RIGHT click on the drive letter and choose Properties, you see the latter smaller amount, if there's nothing wrong with the software partitioning and formatting.

If you consistently can't see folders or files that you're SURE you could see previously, then there's something wrong with the file allocation table(s).
(NTFS partitions have one - the MFT - FAT32 and FAT partitions have two identical ones, only one of which is used at a time.)

Unplugging an external drive while Windows is running without clicking on the Safely Remove Hardware icon and choosing to STOP accessing the drive partition is a COMMON way the partition table or software partitioning data can get damaged.

Report •

March 20, 2012 at 13:39:12
I appreciate your wealth of knowledge.
The previous solutions haven't worked for me in my case.

If there is a file allocation problem is that fixable?
This is a ntfs drive so that would be mft then?

I do normally only plug one usb in at the back, i have 4 at the back and 2 at the front.

In my computer the drive does show the correct stats for the drive.
It does tend to slow my system down though when i have it plugged in.

Hopefully some of this can be recovered.

Thank you.

Report •

March 21, 2012 at 07:15:57
"This is a ntfs drive so that would be mft then?"


""Also the external sometimes shows the folders as empty but shows the entire drive the correct 187 gb.""

"Whatever you see or don't see should always be the same "
.....BEFORE you attempt to fix anything. .

"I do normally only plug one usb in at the back, i have 4 at the back and 2 at the front."

In that case what you see or don't see on the external drive should always be the same.
Are you using the USB cable that came with the drive, and / or the same USB cable tht worked fine with the drive previously ?
Have you tried plugging it into a different USB port back there to see if what you see stays consistent ?

You MUST fix the Write Delay Failed problem FIRST, BEFORE you attempt to fix anything else, otherwise you may cause data damage that can' t be fixed.

Once you have fixed that you may find there's nothong wrong with the MFT.

Report •

March 23, 2012 at 09:11:56
Still no luck with any of the above but i will keep trying all options.

I have tried all 6 usb connections and am using the cable that came with the drive.

A local computer shop suggested trying linux.

Is that an option to attempt?

Report •

March 23, 2012 at 09:30:41
Having reviewed all previous responses here I don't see that you have mentioned if this external is AC powered or not.

Also, is the drive 1.5TB or not.

If so, is it partitioned as a single partition?

If not, list all the partitions including capacity and free space.

Finally, go to Disk Management with the External connected. Right click on the listing for that external and select Properties> hardware. Then highlight the drive from the list and choose properties again. Select policies and list how your drive is currently set.

The above instructions are for Windows 7. Hopefully they are close to the same in WinXP.

Report •

March 23, 2012 at 12:15:36
For Windows....
"You MUST fix the Write Delay Failed problem FIRST, BEFORE you attempt to fix anything else"

You probably must do that no matter what.

I doubt that the situation would be any different for Linux, though the message would probably be different.

It's extremely unlikely but possible the problem is with your own Windows installation. Have you tried connecting the drive to other computers ?

It's possible that the circuits in the external drive enclosure are defective. You could try removing the hard drive inside of it (which would void the external drive's warranty) and either install it internally in a computer, or use another suitable external enclosure or external adapter to connect the hard drive to another computer so you can test the drive.

Report •

March 23, 2012 at 12:17:06
Yes the external is 1.5 tb on one partition- a mistake i guess.
It is ac powered.
Under "policies it is set at optimize for quick removal.

Appreciate all the feedback,Thank you.

Report •

March 23, 2012 at 12:41:43
You stated above that you use the safely remove icon but if you have the drive configured for fast removal you shouldn't see the icon for it. You may be confused by seeing an icon for the enclosure. Would say Mass Storage Device or "eject USB 2.0 drive kit. Below that should list the actual drive model.

I suggest you change the setting to Better Performance. Click on the blue information at the bottom of that screen to view "More information about write caching settings".

If you did lose data due to improper removal or power interruption that data is now lost. If the file was large there may be a listing for it but the file may be incomplete.

Is was covered in #4 above by Wizard Fred.

To safely transfer files I suggest you use Copy/paste then delete the original. However, as Fingers stated above you should always maintain at LEAST 2 copies of any files you wish to keep. ALL hardware can fail, become misplaced, lost or stolen.

I recommend optical media for the safest and most cost effective backup of files.
Once a disk has been created it can be duplicated for pennies. You can then store in a fire safe or even off site. The more mission critical the data, the more care you should take. files that can't be replaced, like family photos are ideal candidates for this type of archiving. I buy SL DVDRs in 100 packs for 20 cents each on sale. They typically hold about 4.4GB without any further compression so they can be read without decompressing.

I suggest you clone the contents of that drive to another location and then send the drive in for warranty. You can then continue to attempt recovery while you get a replacement drive.

Report •

March 23, 2012 at 19:00:56
The best solution for recovery is to copy off the files to another drive. It is almost impossible to repair errors in place if there are multiple errors with large files.

Report •

March 24, 2012 at 06:53:35
Run sea tools on the drive? Nothing but problems with the sea gate 1.5tb drives. U get a write delay when the drive does ot respond. So, either chipset drivers, USB cable, sata controller or the drive. Tire off all power prions on ur USB and system and check from there. When I say controller I mean the controller in the external case, not the one on ur mainboard.

Report •

March 25, 2012 at 09:48:12
Thanks again for the knowledge.

I've to tried to move the files elswhere but i i get a message "semaphore timeout period expired"

I also got a message about cannot save to the '$extend\ $usnjrnl:$j"
Could this be corrupted and cause all these issues?

I'm going to take the drive to a windows 7 computer and see what comes of it.
I'll try it on a linux system early this week.
I'll post when i have any results.

At this time i cannot open the drive as the drive under warranty for a little longer.

Thanks for any feedback

Report •

March 25, 2012 at 12:15:27
Again, clone the entire drive to another hard drive then think about warranty repair or replacement. Buy a second drive so you can have redundancy.

Report •

May 13, 2012 at 10:52:10
First of all sorry for the tardy response time.

I would like to thank everyone for help.

I unfortunately was not able to fix the drive.
It took me quite sometime to remove the data that i need using the "cut and paste|' method did work.

Seatools wasn't able to see the serial number, the short generic test "failed"
The long generic test was still going after 24 hours with about 250 errors, so i stopped it.

Seagate was very helpful through emails and a quick phone call during the return warranty process.

I had a replacement drive in days after filling out the online return warranty.
Choose the option that you pay 9.95 {Canada and U.S.A. only}
They'll ship your drive before you ship your old one...plus you get a return shipping label depending on where you live...either McAllen, Texas or Burlington, Ontario

Just to benefit others....make sure to keep your packaging and receipt as this will be very important to be able to return it under warranty.

I emailed them my original receipt for proof of when i bought it and they put it under warranty form one year from date of purchase.
The reason was the warranty starts from when they ship it to the store.

Thanks again to all.

Report •

May 13, 2012 at 11:37:49
"First of all sorry for the tardy response time."

Better late than never.
So - the drive was definately failing.
Thanks for the Thanks and for "typing up the thread".

"(Choose the option that you pay 9.95 {Canada and U.S.A. only}"

I have a Seagate 500 gb SATA II hard drive that I need to RMA, but I couldn't get that option to accept my Mastercard "Chequewise" chip card. I tried twice.

I thought maybe Seagate can't accept credit cards with a chip on them yet, but it could be that didn't work because it's a "Chequewise" card, which has happened a small number of times previously when i tried to buy something on the web for the previous version of the card that did not have the chip.

Did you use a credit card that has a chip on it ?

The Mastercard "Chequewise" card was issued by my bank - Servus, in western Canada, and it's used the same way as for certified checks - the card draws from a bank account that must have the funds in it, and once a transaction has been completed the funds for that transaction are "frozen" - untouchable by the person with the bank account - just like they are when a certified check has been issued.
In most cases, when you use the card for transactions as a credit card, you have no problem unless the bank account it draws from has insufficient funds.
You can also optionally use it as a PIN card at automated bank teller machines.
Before it had the chip on it, it was like a debit card except you did not need to punch in any numbers - it was treated just like a credit card, almost always.

Report •

May 13, 2012 at 15:00:55
I used a chip card without any problems.
Give your credit card a call see if they know something.
You could either email seagate resellerrma@seagate.com
or call 1-800-732-4283.
I'm in Ontario so it could just be card related.

Let me know.

Report •

Ask Question