Solved Windows 7 pro 64bit blue screen of death after 40 mins.

August 9, 2012 at 14:45:41
Specs: Windows 7 pro 64 SP1, i5 2500K/8GB 1866
My computer (Win 7 pro 64) has started giving me the BSOD after being on for about 40 minutes. After shutting it down, it will start up again no problem and then 40 minutes later the same thing. I've run numerous virus scans, tried numerous restore points... nothing works. Any suggestions?

See More: Windows 7 pro 64bit blue screen of death after 40 mins.

Report •

#1
August 9, 2012 at 15:49:26
Hmmm...those are always tough to diagnose. If you're powering back up immediately after the first blue-screen, and it takes another 40 minutes for the next BSOD, then I'd suspect that it possibly isn't heat-related (since the components are already warm from the previous session). It could be capacitance related (assuming it discharges completely in just a few seconds), so I'd start there. I'd also consider running HDD diagnostics and RAM tests as well---yes, both potentially heat-related components, but there may be something deeper in those two items going awry...

"Channeling the spirit of jboy..."


Report •

#2
August 9, 2012 at 18:35:48
Thanks for the response. I've tried testing the memory using the windows utility and it reports no errors. Also, I've monitored the temps in my system and everything is nice and cool. I've disassembled and reassembled my system as well.

And yes I can restart the computer immediately after it shuts down.


Report •

#3
August 10, 2012 at 14:42:25
✔ Best Answer
Problem solved! Seems it was a firmware issue with my SSD drive. A quick update and voila!

Report •

Related Solutions

#4
August 10, 2012 at 16:05:27
Unusual, but glad you got it working nonetheless...

"Channeling the spirit of jboy..."


Report •

#5
August 10, 2012 at 22:49:11
I use a Crucial M4 60 GB SSD as my system drive. Apparently a few people with older firmware have had the same problem as mine. For everyone using an M4, update the firmware for it. This problem started happening after my system worked flawlessly for almost a year, and then out of the blue...

Report •

Ask Question