windows 7 loses usb drive says to format

March 8, 2011 at 12:58:57
Specs: Windows 7
usually after I take a break and come back my external hdds are gone (fat32 drives, external psu, desktop machine) and there is a message saying to format the drives.
usually the drives are there and work fine; sometime the error pops up.
I can power down and reconnect as a workaround.

See More: windows 7 loses usb drive says to format

Report •

March 8, 2011 at 19:59:29
You are using the plural when mentioning your external drive. If you have more than one connected you may be overloading the USB controller. Are these drives self contained or do they have 120VAC power supplies?

Report •

March 8, 2011 at 20:06:06
External hard drives and external optical drives require that the USB port they plug into can supply 500 ma of current.

Troubleshooting USB device problems including for flash drives, external drives, memory cards.
See Response 1:

Check that out first.

Rarely, not all the ports on the back of a desktop case may be able to supply 500ma each.

If you have a desktop computer, Note that I answered a Topic on this site where a guy had an external drive, which does require the full 500ma, connected to a port on the back of a desktop case - it would not work properly when a webcam was in the port next to it, but it worked fine when the webcam was unplugged. Ports on the back of a desktop case often have two ports connected to the same USB controller module that are ports one above the other - you could try connecting the cable to one of those and leaving the other un-used.

Examine the USB port and the plugs on the USB cable you're using to to see whether they're damaged.
E.g. Bent - such that the fit of the plug is loose - stretched outer metal shell in the port, squished metal outer shell on a plug; bent or loose contacts in the port or plug, the plastic blocking plug that prevents you from plugging in a USB plug upside down is loose or missing.

If you're SURE the USB port can supply 500ma, but ... get messages about the drive not being formatted or if you can no longer see the drive in My Computer or Computer or Windows Explorer...

If you have not dropped the drive or otherwise damaged it, your problem was probably caused by you NOT clicking on the Safely Remove Hardware icon in your Taskbar and STOPping accessing the drive BEFORE you unplugged the drive while Windows was running.
There are several programs that you could try that will probably fix your problem.

Specifically, links to some programs that can repair the data damage are here -
see response 2:

That post also has info about testing the external enclosure's hard drive. Apparently, the Windows version of Seagate's SeaTools can test any hard drive brand when it's in an external enclosure.
Do the long test.

Report •

March 9, 2011 at 01:04:47
Thank you for these answers. I do have an external psu, it is one drive with two partitions, hence my incorrect usage of the plural.
Using a new cable and single USB port, upon further observation, the power seems to be cutting out. I ran the WD diags on the drive; it was found and tested OK.
further testing tomorrow to attempt to isolate the root cause and verify my earlier observations.
cheers, eddacker
P.S. it is a SATA drive in an external housing used for file archives only. I have a (sort-of) recent backup image.

Report •

Related Solutions

March 9, 2011 at 01:58:02
Go to Device Manager> disk drives. Right click on the USB drive and choose policies. What options are checked in that screen?

Report •

March 9, 2011 at 04:41:04
It was set to the default: Quick Removal
I swapped it to Better Performance and started the drive (turned it on)
It is now showing as normal, however, time is required to complete the test.
I am now leaving for dinner; let's see if it is still there when I am back in an hour.

cheers, mate

Report •

March 10, 2011 at 13:12:38
SOLVED (for now :))
USB cable looked fine and in a single rear port, but I changed both anyway.Checked all connections inside and out with no errors
ran one of my live CDs and drives were all there
ran some diags and all hardware looked good. but it looked like problems with partition table.
let it run on Linux for a few hours while I was out to see if heat was a problem.
restarted in windows and ran Easeus partition recovery.
drive has been running most of today and it's all good for now.

Report •

Ask Question