win98se hang usb

October 2, 2009 at 06:02:29
Specs: Windows 98
If I start my win98se computer with a USB device connected at bootup the computer will freeze. After rebooting a few times to safe mode and shutting down with no USB devices connected then the computer will boot into win98 and I can then connect the USB modem and get on Internet. I have the same problem if the USB printer is connected so I know it is not just an issue with the USB modem.

This never used to happen so I am wondering what I might be able to do to solve the problem. I have also recently started getting registry checker blue screen errors after a few hangs as well. Is there a way to check for USB issues? What should I try to do to resolve this?

See More: win98se hang usb

Report •

October 2, 2009 at 07:40:17
Made any changes to the BIOS lately? It sounds like the boot order has been changed to see devices other than CD>floppy>HDD first.

Report •

October 2, 2009 at 08:40:53
Depending on how old your mboard is, some older bioses have obscure settings in the bios Setup that must be enabled in order for USB devices to be detected correctly while booting.

Tell us the make and model of your brand name system, or if you have a generic desktop system, the make and model of the mboard.
The specific model of a brand name system is shown on a label on the outside of the case somewhere, or it can often be determined by going to the brand name's web site.
The model, sometimes the make, of a mboard in a generic desktop system is usually printed on the mboard's surface in obvious larger characters, often between the slots.

USB devices may not work correcly when they're connected to certain USB ports e.g. ports in a hub or on the front of a desktop case. If you have a desktop computer, you may have an IRQ sharing problem you need to fix.
See response 3 in this:

Also - if you are using a USB extension cable, some of them have inadequate wiring and will not work properly with some USB devices.

When you first install a USB printer or USB modem, and many other more sophisticated USB devices, you are are almost always required to NOT plug in the USB connection to the device until the proper software installation for the device has been installed. You are often prompted to plug in the USB connection after some of the software has been installed, but you should NOT plug it in prior to that.
If you had it plugged in prior to that, the software is likely to have not been installed properly, and you probably need to un-install any listing for it in Add/Remove prrograms, unplug the USB connection, and install the software properly.

It is usualy a BAD idea to install drivers for a device while booting, BEFORE the proper software installation for it has has been installed, when Windows detects a new device while booting, you have it search for drivers or it automatically looks for drivers, and when it doesn't find any, it prompts you to show it where the drivers are located. In most cases, if you do that, the device islikely to not work correctly, and some of the software for it may not install properly or not be installed at all. CANCEL installing drivers while booting, let the desktop load, then install the proper software installation.

AFTER the proper software installation has been installed, if Windows detects something about the device while booting and wants you to allow it to search for drivers or point to where the drivers are for the device, go ahead and do that.

Sometimes 98SE and previous back to 95 requires files from the Windows CD while installing software for a device. If the Windows CD has been inserted in a drive, it assumes the CD is at a certain location, but it often makes the WRONG assumption and can't find the files on the CD. You often have to correct where Windows is looking to the drive letter for the drive the CD is in, and have it look in the \Win98 folder on the CD. Almost all files you need are in the \Win98 folder.
If you skip installing files from the Windows CD, if the device works at all it's likely it won't work correctly.

"I have also recently started getting registry checker blue screen errors ..."

98SE scans the registry for errors in the background while booting by default - usually it finds no problems and the boot continues, no problem.

If 98SE is shut down improperly.....
- you pressed Alt-Ctrl-Del twice, or you pressed the Reset button while Windows was running
- your computer froze, those two things would not work, and you held in the power button until the computer shut off, or you switched off the AC power to the computer

..... it's perfectly normal for you to see the blue screen saying your drive(s) are being checked for errors while booting the next time you boot.

On the other hand, if you are frequently getting these blue screens while booting for no apparent reason, that probably indicates you have a hardware problem.

If the computer black screened and rebooted for no apparent reason, that's NOT normal behavior.


See response 2 in this - try cleaning the contacts on the ram modules, and making sure the modules are properly seated:

For a laptop, you must remove both its main battery and AC adapter before you do that.

Check your hard drive with the manufacturer's diagnostics.
See the latter part of response 1 in this:

(thanks to Dan Penny for this link:)
Hard Drive Diagnostics Tools and Utilities

If you don't have a floppy drive, you can get a CD image diagnostic utility from most hard drive manufacturer's web sites, but obviously you would need to make a burned CD, preferably a CD-R for best compatibilty, on another computer if you need to.

If the hard drive itself tests okay, any data problems found can be fixed, one way or another.

Check your PS.
Check the current voltage readings in your bios Setup.
See response 4 in this:

Open up your case and examine the mboard to see if you have bad capacitors, and/or other findable signs of mboard damage .

This was the original bad capacitor problem - has some example pictures.
History of why the exploding capacitors and which mboard makers were affected:

What to look for, mboard symptoms, example pictures:
Home page that site
- what the problem is caused by
- he says there are STILL bad capacitors on more recent mboards.

98SE doesn't have any built in support for detecting or providing the drivers for USB 2.0 controllers or USB flash drives or lots of other USB connected devices that did not exist when 98SE was first released.
The USB devices it can't detect with what's built into Windows must have drivers available for them for 98SE,
OR - there are generic drivers available on the web that have been developed by third parties, BUT they DO NOT work properly with all devices.
E.g. the generic USB drivers package I've tried works fine in 98SE for USB flash drives, memory card readers, and connections to cameras that don't have 98SE drivers available for them, but they won't work with iPod anything. That particular generic drivers package has no un-install program available.

Report •

October 2, 2009 at 10:13:41
At what point does it freeze--before or after the OS starts to load?

What do you mean by 'registry checker blue screen errors'?

Report •

Related Solutions

October 3, 2009 at 06:02:53
The freeze occurs after the Win98 splash screen
disappears and a dos looking window appears
[it just shows C:/ basically] for a few seconds and
will then boot up windows. However, the freeze occurs
on this dos window right after the Win98 splash screen. After a few freezes, instead of the regular
'scan disk' blue screen, I get a 'registry checker.....
'enter'.... you have restored a good registry' message.
This only occurs a few times now and then.

Thanks for the advice everybody and I will check into it.

Report •

October 3, 2009 at 06:08:34
Btw the MB is a Gigabyte GA-8IRXP.
I did discover that, if after I get a decent boot up and then
connect the usb, that I unplug the USB before shutting down, then the subsequent bootup will not
freeze on me. At least thats a functioning system for now.

Report •

October 3, 2009 at 08:36:03
" After a few freezes, instead of the regular
'scan disk' blue screen, I get a 'registry checker.....
'enter'.... you have restored a good registry' message. "

That is NOT NORMAL if you are frequently getting that !
I have been using Win 98SE since the beginning of 2000, and have only gotten that a few times in all that time, when a system has nothing wrong with it.

The most likely things that could cause that......

- you have a problem with the connection of the ram in the ram slots - try cleaning the contacts on the ram, re-seating it - see the info in response 2 above

- you are using ram that is not 100% compatible with the mboard, that is producing a small amount of ram errors.

If you do a ram test, do that AFTER having tried cleaning the contacts and making sure the ram is seated properly - otherwise any errors found may be FALSE.
If the ram is incompatible with the chipset, or on more recent computers, incompatible with the memory controller built into the cpu, it will likely FAIL a ram test - that is NOT a true indication of the ram being faulty - there is probably nothing wrong with it, and it will pass the test if installed in a mboard it is compatible with.

If you want to try a memory diagnostic utility that takes a lot less time to run a full pass than memtest86 does, this one is pretty good - Microsoft's
Windows Memory Diagnostic:
It can be toggled (press T) to do a standard or a more comprehensive set of tests - use the default 6 test one first - if it passes one pass of that, use the latter one. A few of the tests in the latter set are intentionally slower.
If you don't have a floppy drive, see the Quick Start Information at that Microsoft link for how to make a bootable CD of the Windows Memory Diagnostic (you need Windiag.iso - you don't necessarily need to use the program they mention to add it to the CD).

- your hard drive is starting to fail - test the hard drive with diagnostics as in response 2 above


"....the MB is a Gigabyte GA-8IRXP..."

GA-8IRXP Support


You MUST install the main chipset drivers - INF Update Utility (or whatever Gigabyte calls the main chipset drivers) - AND the IAA (Intel Application Accelerator; install it after the main chipset drivers) in order to be sure the operating system has the proper info about your mboard including it's USB support, and to have the IDE drive controller(s) run the drives as fast as the chipset is capable of running them.

If you're not sure whether both of those were installed, install at least the INF Update Utility (or whatever Gigabyte calls the main chipset drivers) - it does no harm to install them again even if they've already been installed. If the IAA has been installed you will find a listing for Intel Application Accelerator in your Programs listings on the first list you see.

(or you can get the latest available versions of those from the Intel web site for the 845 series)

"I did discover that, if after I get a decent boot up and then
connect the usb, that I unplug the USB before shutting down, then the subsequent bootup will not
freeze on me."

You shouldn't ever have to do that (if the USB devices are plugged into ports they should have to problems with, according to the info in response 2) !

You haven't said what specific USB devices you're having problems with.
There are some USB devices you're NOT supposed to unplug while Windows is running unless you click on the Safely Remove Hardware icon in your taskbar and choosing to STOP accessing them. E.g. flash drives, memory card readers, external drives, cameras. In 98SE, the Safely Remove Hardware icon is usually a grey rectangle with a bright green arrow on it.

Report •

October 4, 2009 at 08:00:02
USB devices unplugged are HP printer and Actiontec modem. However, they worked fine for a long time.
I did do a step by step confirmation boot up and found that
after msmouse.vxd, the system would hang if I typed Y.
When I rebooted and typed N, it paused a little but then booted ok but the little scroll wheel on the mouse would not work--no big problem. Not sure if this is significant or not.

I will try a simple reinstall of win98 [running setup] and
see if that helps any. Thanks for your reply I will check out
gigabytes site.

Report •

October 4, 2009 at 11:33:09
Install the main chipset drivers if you haven't already. If you're not sure whether they have been installed, install them anyway.

You can do an "overtop" Setup - install Windows in the SAME folder it is in now - usually that's C:\Windows - if you do that you don't lose the present settings and program installtions etc, and you won't need to supply a Product Key, unless certain essential data in Windows is corrupted.
With some CDs, you must use a 98SE Startup disk, load CD drive support (the default), and then run Setup on the CD - just type; Setup.
If you don't have the 98SE Startup disk, you can make it in Control Panel - Add/Remove Prgrams.

I have one Logitech combo USB/PS2 mouse model that conflicts with some certain other USB devices when it's connected to a USB port, but there's no problem when it's connected to a PS/2 port via the USB to PS/2 gender adapter that it came with .
Try connecting a different mouse if it's USB, or if it's a "combo" mouse try it connected via it's gender adapter to a PS/2 port.
A simple gender adapter will NOT work with a mouse that is NOT a "combo" mouse. The adapter is usually colored green - one for a keyboard is usually colored purple - the adapter for a mouse may not work with a keyboard and visa versa because the necessary connections are not there in the adapter.

See the info at the first link in response 2. If you have a desktop computer, you may have an IRQ sharing problem you need to fix.
If you do have that prblem and fix it, the directions about re-loading the USB stack are for 2000 and XP - I also have ones for ME and previous if you need that.

Report •

Ask Question