Win7 USB ports not up to speed?

Custom / CUSTOM
May 4, 2010 at 01:31:40
Specs: Microsoft Windows 7 Ultimate, 2.394 GHz / 6143 MB
This is a bit of an odd problem to me. When I bought this computer froma friend it had XP Pro on it and all was well. I have switched to Win 7 and all was still well for a while. About a week ago I I backed up all my data to another machine and wiped both my drives clean (formatted) and reinstalled Win 7 along with all my drivers for all my hardware. I brought back all my backed up data and everything seemed fine. Now I am getting messages about my front usb ports not being up to speed. It says something to the affect that there are faster usb ports on my system. I have looked all over the motherboard manufacturers site (Asus) and can't find a driver for this not even for XP. I do have the motherboard cd it has drivers for usb but they are for XP and win 7 will not allow me to install. What did I miss? I did not have this issue when originally installed 7 and I have reformated before without this issue.

See More: Win7 USB ports not up to speed?

May 4, 2010 at 09:31:07
It's difficult to help when you provide zero info about your system. It's possible that the front USB ports are 1.1 only. If not, the drivers you need *should* be available at the Asus site, possibly included in the chipset drivers? If Win7 drivers aren't available, try the Vista drivers.

Report •

May 4, 2010 at 10:20:33
If the mboard was made after about 2003, it supports USB 2.0.

You don't need to be looking for USB 2.0 drivers. The support is already there in the operating system, but the main chipset drivers have to be installed before it's installed.

All Microsoft operating systems Win 98 and up install USB 1.x support automatically when you install the operating system. USB 2.0 controllers also support USB 1.1 .
Installing the main chipset drivers for the particular mboard after Windows Setup has finished installs the USB 2.0 support, if the mboard is capable of supporting USB 2.0. The USB 2.0 support is built into the Windows 7 (and Vista, and XP with SP1 or greater updates) operating system, but the main chipset drivers for the mboard have info (in *.inf files) the operating system needs to know in order to enable the proper USB 2.0 support, so the USB 2.0 support is not installed until the main chipset drivers have been installed.

Since you say you installed the drivers for the mboard, assuming you installed the main chipset drivers, the USB 2.0 support has probably already been installed.

Take a look in Control Panel - Classic View - Device Manager - Universal Serial Bus Controllers.
If you have a listing for an Enhanced USB controller of some sort, the USB 2.0 support has already been been installed.

- If you only get the message when you plug into the front USB ports, for some computer cases, the case wiring between the ports and the USB header on the mboard is inadequate and it cannot support USB 2.0 specs. That's more likely to be the situation for an el-cheapo computer case.
If you're handy, if you replace the inadequate wiring with wiring that supports USB 2.0 standards, the front ports will then work fine for devices that work better if the port supports USB 2.0 .

- I have seen a few cases where you get the message when you plug into SOME directly connected to the mboard USB ports on the back of the case in the I/O area where most of the ports are, but not from others there. Try another port there in that case.

- You MAY get the message in other circumstances regarding USB ports not physically built into the mboard.

See response 3 in this:

Also - if you are using a USB extension cable, some of them have inadequate wiring and will not work properly with some USB devices.

Report •

May 4, 2010 at 17:00:24
Okay this computer had usb 2.0 via the front ports for more than three years altogether. No hardware was moved or changed in anyway during the reinstall. Chipset drivers were insatlled. Enhanced USB controller is listed twice in device manager with no issues ( yellow exclamation point or red X's).

The device that brought this to my attention is an 8GB flash drive. I tried the drive in all of my rear ports to check and they all seem to be fine. So I opened the case up to check the front panel connections, time for dusting anyway, disconnected and reconnected all front panel connections. This did not help. Being a little adjitated I went back to device manager and uninstalled everything under universal serial bus controlers. Learned that when I do that I loose control of my usb optical mouse and my usb keyboard. Anyway after a reboot all was reinstalled. I pluged in my flash drive and same issue. Was going to give up but tried another port, there are 4, and it worked. Tried the others they all now work it is just the one that has lost the high speed at this point I am assuming the port is going or has gone bad as all four ports are on the same cable.

Thanks for your responses guys sorry I kind of wasted your time.

Report •

Related Solutions

May 4, 2010 at 18:24:57
"Tried the others they all now work it is just the one that has lost the high speed at this point I am assuming the port is going or has gone bad as all four ports are on the same cable."

The cable probably has wires for two individual ports - e.g. at least 8 wires connect to the one USB header.
Since you say the front ports were working fine for USB devices that work better if the port supports USB 2.0 before, one of them is probably physically damaged.
Take a close look at the front port that is un-reliable. You will probably find there's something physically wrong - e.g. the external metal "shell" is bent such that it's not a tight fit when something's plugged into it.

Report •

Ask Question