Why isn't Windows 7 automatically recognizing USB Turntable?

November 14, 2016 at 17:42:47
Specs: Windows 64
Numark turntable not recognized on Sony Vaio Windwos 7 laptop.

Previous laptop had no problem recognizing USB turntable. Plug it in, after a few seconds it was listed as a recording device. Still works on old comupter, just checked.

I plug it into the newer laptop and nothing. No error message, no nothing. Just like nothing is plugged in.


See More: Why isnt Windows 7 automatically recognizing USB Turntable?

Report •

#1
November 14, 2016 at 18:06:41
A long shot but try this:

Turn off laptop and remove main battery. Hold Power Off/On button for at least 20 seconds to discharge the motherboard components. Assembly again and see if it helps.

Otherwise:

1. Does the turntable appear as a drive in "Computer"?

2. See if there are any errors showing in Device Manager.

Always pop back and let us know the outcome - thanks

message edited by Derek


Report •

#2
November 14, 2016 at 23:18:04
What OS is on the 'old' computer?

Do other devices work in that USB port?

Try connnecting it through a powered hub.


Report •

#3
November 15, 2016 at 02:51:10
Could be the USB cable. If your newer laptop has USB 3.0 (SS USB) then a 2.0 cable may not be letting it interface. Hopefully it is in your device manager like Derek says. Dave's suggestion may be all you need if not. I suggest startech. Great stuff. I have about 3 different hubs from them.

https://www.startech.com/USB?c_filt...

I don't need to be right, but I am never wrong.

message edited by stiefler182


Report •

Related Solutions

#4
November 15, 2016 at 04:50:56
Old computer was windows vista. I can take the turntable, plug it into the old vista computer, and it's immediately recognized. (same cable)
I've tried all ports on the newer computer and nothing. Just sits there not doing a thing

message edited by knownote


Report •

#5
November 15, 2016 at 07:02:22

Report •

#6
November 15, 2016 at 07:18:04
Yes, that was one of the first things I did when searching the net for the solution. did not see my specific issue on there. Their solutions involved problems with error messages. I get no messages. Just acts like nothing is connected

Report •

#7
November 15, 2016 at 08:09:46
Did you check the suggestions in #1?

Always pop back and let us know the outcome - thanks


Report •

#8
November 15, 2016 at 08:31:42
Try plugging it in to different USB ports on your laptop.

Report •

#9
November 15, 2016 at 08:42:51
Already tried all the ports. See #4

Report •

#10
November 15, 2016 at 08:47:00
#1 doesn't mention ports.

Always pop back and let us know the outcome - thanks


Report •

#11
November 15, 2016 at 08:50:19
I was replying to thx 1138's suggestion

Report •

#12
November 15, 2016 at 09:59:28
Some USB devices require drivers to be installed before the device is connected. Are there Win7 drivers available?

Report •

#13
November 15, 2016 at 12:13:04
Hi, it appears the Numark is a plug and play device..

Have you asked the question, here:-

https://www.numark.com/support

Good Luck - Keep us posted.


Report •

Ask Question