Why is there no power going to my motherboard

Antec New solution nsk1380 chassis
January 29, 2011 at 14:20:29
Specs: Windows XP Prof SP3, 2GB Crucial
Hello All,

I have recently replaced the motherboard, RAM and the PSU in my Antec NSK1380 case. I have double checked all connections on the Asrock P4i945GC motherboard at least a dozen times, still no life.

I have also tried a different processor and not having the DVD drive connected. I have tested the WD Caviar Blue hard drive in another machine and it works fine.

Has anyone come across anything similar? If so, I could really do with some help as I am at the end of my knowledge.


See More: Why is there no power going to my motherboard

Report •

January 29, 2011 at 14:29:03
Start with one stick of ram, mouse, keyboard and monitor. See if it posts. If not it's a bad board or psu. See if the mobo lights up if it has a light. Check to see if the fan spins on the psu.

Report •

January 30, 2011 at 05:47:00
Thanks for the advice Grasshopper. I've tested each, in fact the Antec PSU, Crucial RAM and Asrock motherboard are brand new. I'll have to get an exchange from the vendor for the motherboard.

Report •

January 30, 2011 at 06:39:36
OK, good luck. You never know with components these days.

Report •
Related Solutions

Ask Question