Why don’t I have power?

October 14, 2018 at 12:59:35
Specs: Win7
I halfway put my laptop back together and powered it on to test it out. The system booted up fine but I noticed that I forgot to plug in the touchpad. While attempting to reconnect the touchpad connector to the motherboard, the laptop immediately powered off. There is absolutely no sign of power, including the battery charging LED. It sounds like I fried the MOBO but I don’t see any visual signs of that. Could there be any other damage besides the MOBO?

(The power supply is verified good)

P.S. I’m an idiot, I know.

message edited by Thamby0113


See More: Why don’t I have power?

Reply ↓  Report •

#1
October 14, 2018 at 13:38:54
mmm - "Never" wise to go inside and make any changes to any computer - whilst the power is applied; be it battery power, mains power or whatever.

You "may" have killed the motherboard; possibly not.

You may have shorted out the battery completely; so with the battery removed and the mains adapter connected (and obviously powered on) is there still no activity?

What make/model is the laptop?

How did you confirm the power adapter is OK?


Reply ↓  Report •

#2
October 14, 2018 at 14:00:29
Toshiba sattelite a505-s6033

There is no power with or without the battery installed. The battery was failing and couldn’t hold a charge, but it didn’t cause any issues before.

I have 2 power supplies, both of which work on my other toshiba and don’t work on this unit.


Reply ↓  Report •

#3
October 14, 2018 at 14:07:20
Remove all power and carefully check your connections again. If they are OK most likely you've popped something on the motherboard. This can happen if you plug things in and out with the power on. It's very easy to short things together,

Always pop back and let us know the outcome - thanks

message edited by Derek


Reply ↓  Report •

Related Solutions

#4
October 14, 2018 at 17:29:42
Yep, I verified all the connections and still no power. I just want to verify that it’s the mobo before I replace it.

Reply ↓  Report •

#5
October 22, 2018 at 06:02:06
have you tried this?:

remove the battery
unplug the power cable.
hold the power button for 20 seconds(this discharges all components)
plug every thing back in& start the laptop
it should start, if not "it's probably fried"

edit: or did you leave something conductive on the laptops Motherboard?

i5-6600K[delid]@4.7GHz/4.3GHz@1.376v LLC=6 | 2x4GB Crucial-DDR4-2133CL15@14-14-14-28 1T 2700MHz@1.35v
MSI Armor RX 570 4GB@1180Mhz core@0.937v/2000MHz

message edited by hidde663


Reply ↓  Report •

Ask Question