Why can't my bios find my IDE devices after changing a P/S?

November 27, 2012 at 12:56:18
Specs: Windows 7 64 Bit Service pack 2, AMD quad core 2 3gig / 8 Gigs
A few weeks ago, I had an issue that resulted in a new power supply. I was worried that the problem would have caused other problems but after installing the new PS, my system booted up and ran fine. It wasn't until I was creating my regular backup's and getting ready to format / reinstall that I realized my DVD drive was missing. I did all the regular steps to fix it, including the upper/lower filter fix in the registry, re-seated the power and ribbon connections and even replaced the DVD drive with a working one from an older computer.

This is where it get's confusing. The replacement DVD worked when I connected it to an external power source (power cable from my Universal Drive Adapter), and it opened and closed, power light came on. but when I connected it inside of my system, no power light and the tray did not open or close and the DVD drive was not found in the BIOS.

Just to fill you in on the steps I took... I made sure the jumpers on both DVD drives are set to Cable Select
Reversed the IDE ribbon
tried a different power cable
Tried the external power cable while connected to the IDE ribbon
Replaced the IDE ribbon with a new one.
Removed power to all other devices (HDD and Video Card)
Tried all of the above steps with both the original DVD and replacment DVD drive.
Connected an IDE HDD to the IDE ribbon - BIOS did not find that either.

I know the easiest way to fix this is to get a SATA DVD drive, but I just want to know if it's possible (since I've never heard of it happening before) for a problem that results in a new power supply to also damage an IDE port. I've always believed that IDE were like cock-roach's and could survive virtually anything

Is there any test I can try to confirm that the problem is the IDE port on the motherboard? I've tried just about everything I can think of, yet there are no IDE Devices being found.

Any input or advice would be appreciated, thanks.

See More: Why cant my bios find my IDE devices after changing a P/S?

Report •

November 27, 2012 at 13:15:09
Don't configure the jumpers for Cable Select, it was a good idea in theory when it was first introduced but it rarely works properly. And don't reverse the ribbon cable either, it is designed to work only one way.

Configure the drive jumpers as Master and Slave (MA & SL). Put the slave drive on the middle connector and the master drive on the end connector.

Report •

November 27, 2012 at 15:47:17
As explained by phil22, it's generally best to configure the jumpers to MAster & SLave rather than using Cable Select. When configuring jumpers in this way, it really doesn't matter which drive is connected to which plug. The only time that matters is when using CS.

You didn't explain how many total IDE drives you have? Avoid pairing up HDDs or optical drives on the same IDE cable. If you have 4 IDE drives (2 HDD & 2 optical), this is the optimal configuration:

primary master = HDD w/OS
primary slave = optical drive
2ndary master = optical drive
2ndary slave = 2nd HDD

Or as an alternate config:

primary master = HDD w/OS
primary slave = optical drive
2ndary master = 2nd HDD
2ndary slave = optical drive

If you only have one IDE port & 2 IDE drives, you have no choice, one master & one slave.

Report •

November 27, 2012 at 17:22:51
thanks for the reply's, I guess I should have mentioned, the DVD drive is the only IDE device installed. I tried again with the jumpers set to Master and the drive plugged into the end port on the ribbon, and it is still not found in BIOS.

The HDD are both SATA Drives, and the DVD is IDE.

Report •

Related Solutions

November 27, 2012 at 19:04:12
It is beginning to sound like you may have your BIOS set up accidentally to look to SATA only and ignore IDE drives. Look for a hybrid or composite setting that allows both SATA and IDE drives or switch over to a SATA DVD drive. Depending on the BIOS and the settings, an all SATA set up might actually be faster on your SATA hard drives.

You have to be a little bit crazy to keep you from going insane.

Report •

November 27, 2012 at 20:46:44
Seems like the tray ought to open and close even if the IDE slot was shot. Try disconnecting the IDE cable from the drive but keep the drive connected to the power. Start up the computer and see if the tray opens. If not, check the power connectors again.

Report •

November 27, 2012 at 21:03:11
I just checked the bios settings, and both the IDE Channel's say "Not Detected". I couldn't find anyplace in the BIOS for Hybrid or Composite settings. I'm using an Asus M3A32-MVP DELUXE Motherboard, I'm looking to check if there are similar settings for Hybrid / Comp settings but since it simply says "Not Detected", I'm not sure it's even looking. I'm not sure where to even look however in the BIOS for that specific setting. I'm from the school of "if you don't know 100% of what a setting does, then don't touch it".

I have tried to open the drive with just power connected to it in the past and it doesn't respond. I have tried it with the DVD drive installed in the case using the tower power supply, and the external power supply from my Universal Drive Adapter (that thing is awesome btw), and except from the first time I connected it, the power light has never come on. That was with the original and new IDE Ribbon. That tray has only opened for me the very first time I connected it, and that was before I was put into the tower. I have also tried multiple power connections as the Power Supply is modular and let's me try different configurations of SATA and 4 pin power connections.Currently the drive is connected with a 4 pin connector to both my Primary HDD and the DVD, so I know there is power going through. And Yes, I have also tried it with a 4 pin connector that only goes to the drive, nothing else, and it still doesn't open. Maybe it's just done.

I'm thinking its got to be the port, and by connecting another device to the bad port, may have done something to the drive itself. What? I have no idea, but either way, it's not opening and not getting found in BIOS.

Thanks again for all the suggestions, I think I'm just gonna toss the while IDE setup and go 100% SATA, since it's only the DVD drive that's IDE now anyway.

Report •

November 28, 2012 at 00:01:13
Some optical drives have a small surface-mount fuse by the power connector. (Years ago I bought a cd burner on ebay that was dead when I got it. I finally figured out it was that fuse.) You say it opened once but doesn't any more. Maybe that fuse has blown.

If I understand correctly you tried to power it when it was connected internally with an external power supply. That might work OK to test the open/close function but when you connect a data cable you may risk some voltage incompatibility since the mechanical power is coming from one source and the data exchange voltages are coming from another--they may not have a common grouind. That's just a guess however. I've never tried anything like that.

But even if the fuse I mentioned is blown it sounds like you may have a damaged IDE port also.

You can always get an IDE card for the DVD drive (unless you get a sata drive). If so you need to make sure it's compatible with atapi devices. Some of those add on cards don't work right with optical drives.

Report •

November 28, 2012 at 05:22:15
There should be a setting in the BIOS to Enable the IDE controller. Maybe it somehow got disabled.

As DAVEINCAPS suggested above, the drive tray should operate with only power connected to it. If it doesn't, then either the drive is defective or the power connector is not providing power.

Report •

Ask Question