When I turn on my computer I get this error m

May 5, 2010 at 02:54:52
Specs: Windows XP
When I turn on my computer I get this error msg:

PhoenixBIOS 4.0 release 6.0
Copyright 1985-2001 Phoenix Technologies
Version 3.15

CPU= intel celeron cpu 2.20GHz
247 system RAM Passed
128K Cache SRAM Passed
System BIOS shadowed
Video BIOS shadowed
Fixed Disk 0: Samsung SV0602H
Mouse initialized
02B0: Diskette drive A error

Press F1 to setpup, F2 to resume

And all the screen is black. I press F2 a hypen comes and all the screen is black. nothing comes in screen & again i restart the system two bip sound comes and same error occurs.there is no floopy drive in this system. & also when i restart the system sometimes shows set date time and also cmos check sum error & also tell me how to replace cmos battery ( if it have cmos battery problem)
but how do I fixed it? Any ideas?

Thanks everyone.

See More: When I turn on my computer I get this error m

Report •

May 5, 2010 at 05:46:52
"247 system RAM Passed"

XP with just 247MB RAM? It must run like sh!t.

"there is no floopy drive in this system. & also when i restart the system sometimes shows set date time and also cmos check sum error"

Your CMOS battery has failed. You have to open the case, find the battery on the motherboard, remove it, get the model number off the battery, then buy a replacement. They only cost a few bucks & normally can be purchased just about anywhere that sells batteries. You do NOT have to go to a computer shop. One of the most common batteries used is CR2032.

How To Install A CMOS Battery

Report •

May 5, 2010 at 07:50:31
The bios defaults are loaded when the Cmos battery is too weak or dead (or if it's installed backwards - the + on the battery should be visible when the battery is installed - or if the battery has a poor connection to it's socket, e.g. the socket is corroded, or if one contact on the battery socket is bent and is not touching the battery).

02B0: Diskette drive A error"

The default in many desktop bioses is for one floppy drive to be enabled; if you're not using one, you may get that error while booting if there is no floppy drive. You must go into the bios Setup and set that to disabled, as well as set the date and time, when your Cmos battery is too weak, or the first time you boot after you have replaced the Cmos battery, then you shouldn't get that error as long as the computer is still running when the battery is too weak (you can Restart the computer and the bios settings will be retained), or after that when you boot after having replaced the battery.

However, you may have something else wrong as well. When you press F2 the computer should boot into Windows, unless you have more than one hard drive, or more than one partition on a single hard drive, and the default Boot Order or similar settings in the bios do not select a bootable drive, or a bootable partition, in which case you must change the Boot Order settings too so you're booting from something that is bootable.

If the Boot Order or similar settings are right, and you do have something bootable, if Windows still won't load, there's something wrong with the hard drive and/or the data on the bootable partition that is preventing Windows from loading.

Check your hard drive with the manufacturer's diagnostics.
See the latter part of response 1 in this:

(thanks to Dan Penny for this link:)
Hard Drive Diagnostics Tools and Utilities

If you don't have a floppy drive, you can get a CD image diagnostic utility from most hard drive manufacturer's web sites, but obviously you would need to make a burned CD, preferably a CD-R for best compatibility, on another computer if you need to.

If the hard drive itself tests okay, any data problems found can be fixed, one way or another.

Report •
Related Solutions

Ask Question