Weird SD Card Issues

May 22, 2014 at 05:49:25
Specs: Windows 7, Intel
Hi Guys,

Ok, i have recently gone through 3 SD Cards trying to get one to work correctly. I intend to use the SD card in my car ro store music on to play through the media player. I have inserted the card into my laptop and managed to copy many albums onto it fine, if i then take the card out safely and reinsert the card i find that the album folder is still there that i had copied but the contents has been deleted. I have had this same issue on all 3 SD cards i have bought and even tried them on 3 seperate PCs whic hall do the same thing. The SD cards as expensive branded ones so not rubbish so dont know what else to try now. All have been formatted and tried ex-FAT and FAT32 but no difference to the outcome. Has anyone any idea what the issue may be?

Cheers,
matt.


See More: Weird SD Card Issues

Report •

#1
May 22, 2014 at 05:59:18
mmm - Basic I realise, but presumably when you have finished using the card (transferring files to it) you do "eject" the card properly; rather than simply removing it?

Report •

#2
May 22, 2014 at 06:16:04
Hi there

Yes this is what i have been doing so very confusing why this is happening.

Thanks
Matt


Report •

#3
May 22, 2014 at 06:22:57
If you don't see the music files on a computer then you are doing something wrong.

What format are the files and how are you placing them on the SD card?

message edited by OtheHill


Report •

Related Solutions

#4
May 22, 2014 at 06:26:13
Perhaps try copying the files to the SD without creating a folder for them - basing this suggestion on OtH's experience?

Report •

#5
May 22, 2014 at 06:26:49
Hi there,

I thought that but looked into the spec for the car and it can take any SD card but only read 1000 folders in the root folder. The problem is happeniing before i put it in my car anyway as mentioned i can copy music to it fine and see the music there in the folders but if i eject the card and then reinsert it to add more the last folders i added are still there but the music is deleted from within them.

Thanks
matt


Report •

#6
May 22, 2014 at 06:28:30
This is not happening to ever album i copy to the card just random ones. One time i may access the card and recopy some music that had deleted itself but this time it may stay and just delete itself again so very odd going on.

Report •

#7
May 22, 2014 at 09:46:22
How are you placing the files on the card?

Are the files MP3?


Report •

#8
May 22, 2014 at 15:59:19
Before removing it after the initial copying, verify the files are actually there and not just showing as links to their previous locations.

Report •

#9
May 23, 2014 at 04:49:32
I have tried highlighting the folders i want to copy over, copying and pasting and dragging and dropping but all have the same random issue.

Have verified the files are actually there, gone out of the new folder and into another then back to the one i copied which was still there and definately not just links.

I have even had one copy fine, took card into car and managed to play the album but when brought back into my PC the album has deleted.

Driving me mad ;-(


Report •

#10
May 23, 2014 at 05:59:53
This issue may have something to do with the Digital Rights Management of the files.

I don't purchase music files so I am not sure what the restrictions are but I am sure there are some.

What is the origin of the files? You haven't answered what type of files they are either.


Report •

#11
May 23, 2014 at 06:26:16
Sorry guys, they are all .mp3 files.

All music has either been downloaded or ripped from my own CD collection - as mentioned though sometimes they will copy on but dissapear later on but another time i try and copy back again they may copy ok and stay there but other files will go.

Thanks


Report •

#12
May 23, 2014 at 14:40:11
Maybe they're there but you can't see them? Choose the windows 7 folder option to view hidden files. There's an occasional problem with files on USB drives becoming hidden.

Also try copying other non-music random files and see if they too disappear.


Report •

#13
May 23, 2014 at 19:09:28
Maybe try syncing the card using Windows Media Player, instead of just copy/pasting?

OMG don't judge me!


Report •

#14
May 24, 2014 at 05:57:17
As per #2 & 3 replies above. Are you sure you are properly removing the SD card using the icon in the tray by the clock.

You may see a mass storage device and the SD card. You should click on the SD card and wait for the message that the device is OK to remove.


Report •

#15
June 12, 2014 at 14:30:17
Hi Guys,

Yes am definitely removing the card correctly ejecting it as should but makes no difference. All files are .mp3. I managed to get a good amount on the SD Card but now have a few more albums to add to it, i have tried adding these using the built in SD card reader/writer on 3 laptops and using USB card reader/writer, tried dragging and dropping, copy and paste, send to, media player sync all copy the new albums fine to the card and can see them fine NOT LINKS, as soon as i take the card out and reinsert the album folders are still there but are empty, i have show hidden files turned on so not just hidden. To repeat this is happening on 3 different laptops, different music, and 3 different SD cards all expensive branded so not junk. I have even removed the DRM from a few albums which worked fine so tried on the new ones but still no joy. Cannot keep reformatting as it takes hours and then more hours to copy back then find out the same problem still exists. Please someone else must have had this issue help before i implode.

Thanks
Matt


Report •

#16
June 12, 2014 at 14:58:53
It is possible you have downloaded a corrupt or malware infected file.

It's a long shot but have you tried scanning your music collection with an antivirus scanner or malware scanner such as Malwarebytes antimalware?


Report •

#17
June 12, 2014 at 16:38:54
What capacity are the SD cards?

When viewing the card/s in Disk management is the capacity shown in the listing there the same as the listed capacity of the card? High capacity cards may not work correctly, if at all in some readers.

What file format are you using? Are you formatting the cards or were they pre-formatted?


Report •

#18
June 12, 2014 at 21:46:21
I still think you're doing something wrong but I have no idea what it is.

Try copying files other than mp3 and also see if it makes any difference if you copy them to the root directory on the flash drive instead of a folder.


Report •

#19
June 13, 2014 at 00:55:06
Ok, i scanned all my files last night with AV and malwarebytes and all come back fine no issues what so ever.

Capacity of 2 of the cards are 32Gb and the other is 16Gb. I have tried .mp3, WMA and M4A all react the same.

I have tried formatting the cards in FAT32 and exFAT but stil no change.

DAVEINCAPS - what could i be doing wrong? most of the music has copied over fine its just gets to a point where it does this each time. Have tried copying into their own folders in the root, into the root iteself not in folder and even copied them last night into another artists folder all with the same results as soon as the card is removed and reinserted either into laptop or into car the album songs have disappeared but the album folder is still there.

Thanks,
Matt


Report •

#20
June 13, 2014 at 02:13:14
You've just copied media files to the flash drives. Maybe the problem is with your media player? Try copying some .exe or text files that your media player won't open and see if they stay.

You seem to have everything else covered. I don't think I've heard of anyone having this problem before so that makes it seem like you're doing something wrong. I just have no idea what it could be.


Report •

#21
June 13, 2014 at 03:41:46
Ok will have a go, cheers DAVE

Report •

#22
June 13, 2014 at 05:00:02
As per #17 above. When viewing the cards in Disk Management does the capacity shown in Disk Management match the known capacity? Your readers may not be capable of handling those sizes.

Report •

#23
June 13, 2014 at 05:12:03
Hi there,

Yes it shows the correct amount for the card. I have even bought a new reader to rule that out but no change.

Ta


Report •

Ask Question