Weak or no signal HDMI Acer Predator

July 22, 2012 at 06:29:31
Specs: Windows 7, intel core i7 / 16gb DDR3
Just bought an acer Predator G3610. When I connect the HDMI cable to my TV it briefly searches for a signal then ends up black saying "Weak or no signal".

I've also tried connecting it to an old monitor that uses VGA(something) and it too registers the computer but stays black.

Any help is greatly appreciated!


See More: Weak or no signal HDMI Acer Predator

Report •


#1
July 22, 2012 at 08:36:27
You need to set the TV to the HDMI port you are connected to. Most TVs have more than one type of input so you need to use the menu to select the correct one.

When connecting to the VGA monitor are you using any adapters?


Report •

#2
July 22, 2012 at 09:14:49
Tried all imputs and all options in the menu. Still no change.

No adapters on the VGA. Is it possible that the cables are obsolete?

And thanks for helping!


Report •

#3
July 22, 2012 at 09:20:05
Are you changing the signal output from the laptop to the external port using the function key + appropriate Fkey?? On my laptop, it's Fn + F4.

Report •

Related Solutions

#4
July 22, 2012 at 09:58:40
It's not a laptop so i have no working monitor. It's basically a big expensive box that beeps and hums.

Report •

#5
July 22, 2012 at 10:09:20
Sorry, I thought it was a laptop model. When you 1st boot up with the monitor attached, do you see the Acer splash screen or nothing at all? If you see an initial display & then it goes black, it's probably due to the resolution setting being too high. And if that's the case, simply tap the F8 key at bootup & select VGA mode.

"a big expensive box that beeps and hums"

If there's more than a single beep at startup, you have an internal hardware problem. If there are multiple beeps, describe the pattern.


Report •

#6
July 22, 2012 at 10:18:29
A predator with GT 440? Looks like a prey to me.

Your TV model number please.

You know the real meaning of peace only if you have been through the war.


Report •

#7
July 22, 2012 at 19:08:11
If you just took delivery of the new computer and you don't see any video you may need to open the case and re-seat everything.

If you bought it local then return it. If mail order, then speak to tech support BEFORE opening the case so as to not void any warranty.


Report •

#8
July 23, 2012 at 04:52:00
The TV is a Samsung SLO1.

The computer only emits only a single beep when activated.

Both TV(hdmi) and monitor(vga) refuses to show me anything despite tapping F8.
No logo or anything, just black and then "weak or no signal".

There is a third port that I think is DVI (I don't know much about this stuff, hence my presence here). It's like the presumed VGA but with more concentrated dots and a cross on one side. Would an adapter work?

VGA -> DVI or DVI -> VGA

What's best?

Also, many thanks to all of you for helping!


Report •

#9
July 23, 2012 at 05:39:46
VGA = analog
DVI = digital
HDMI = digital + audio

I think it's time to return the tower for a refund or exchange.


Report •

#10
July 23, 2012 at 06:04:01
I agree with riider but it wouldn't hurt to re-seat RAM and V-card.

You know the real meaning of peace only if you have been through the war.


Report •

#11
July 23, 2012 at 12:49:44
Don't void any warranties by opening the case. Get permission first. May be just a case of a loose cable or card.

A single beep is good. No video on boot is bad.


Report •

Ask Question