WD Green 1TB HD suddenly not detected in BIOS

Wd Caviar green 1tb 3.5
January 11, 2011 at 23:47:23
Specs: Windows 7 x64, i7 860 / 4GB
I have a WD Caviar Green 1TB drive that suddenly one morning was not recognised by BIOS.

I got a boot error, and was promted to insert a proper boot device. I loaded the Win 7 disk, knowing I had previously had a boot sector problem that was solved by doing a boot sector repair from the disk. That didn't work however, and I found that the Win 7 disk did not find any disk for installing win 7 on. Thats when I entered BIOS and couldn't find my drive.

When listenning to the drive when I power on the computer, it starts to spin up, and after a couple of seconds it starts "scipping" ("spin, tick, spin, tick, spin, tick" approx 1s intervals) much like a scarred CD that the cd-drive struggles to read, but a bit more subtle.

I have bought a new Corsair SSD wich was found easily in BIOS, and installed win 7 and booted perfectly.

As you might have antisipated, I have data on the drive that I like to recover. The disk is about 1,5 years old, and still under warrenty (at least by Norwegian rules not sure about WD warrenty?) But a warrenty claim will probably just give me a new drive? They don't repair the old one? (if its broken)
Could it be other issues than physical harddrive failure that keeps my disk from getting on it's feet? My motherboard is an ASUS p7p55d PRO.

I guess an option is to buy a new equal disk, and swap some parts. is this easy, or will I be lucky not to just ruin both of them? Does it involve soldering? This of course will void my warraty for both the drives.

Any suggestions?

See More: WD Green 1TB HD suddenly not detected in BIOS

Report •

January 12, 2011 at 05:44:54
Everything you described indicates a failed hard drive. Chances of retrieving the data are slim unless you take it to a data recovery service. There's not much you can do if the drive's not being recognized but you can try ry running the Western Digital diagnostics to see if it will produce an error code that you can use for warranty replacement. You can also try the "freezer trick", that may buy you enough time to retrieved some of your files.


I'm sure swapping parts will void the warranty. You can change the circuit board but from what I've read, they need to be identical. Hard drives have to be assembled & disassembled in a "clean room". If you open the case & expose the platters to the air, they will become contaminated.

Report •

January 14, 2011 at 01:06:46
Tried the freezer trick, but to no sucsess. Although it seemed a little better regarding the noice and spin up, but there were still minor clicking and no detection in BIOS. Also my windows (Run from SSD) seemed unstable with tendencies to flickering screen.
Will the WD diagnostics tool be able to do anything if the disk is not recognised by bios?
If I could manage to find a similar donor drive, I guess it is the matter of swapping the right part to get it to run again? First PCB, then head or platters?
Could one get a "non identical" drive and swap the disks? perhaps they are similar in all the drives, and just swap the ones witout information wtritten to it with the ones with information on?

Report •

January 14, 2011 at 04:32:08
I hope that you have an industrial strength clean room if you're thinking in terms of swapping internals! Don't even consider it.

Report •

Related Solutions

January 18, 2011 at 22:26:00
Try booting your machine, then - after 20 seconds or so - CTRL + ALT + DELETE to force an immediate reboot. My WD 1TB Green edition drive *never* gets picked up by a cold boot, because it takes so long to spin up. By the time it's "ready" the BIOS is done with detecting, and moved to to booting. Do a hot re-start, and your drive may have spun up, get detected, and then boot normally.

Report •

March 25, 2011 at 11:54:18
Ok... So some time have passed, and i have finally managed to get hold of a identical PCB.

Swapped it, and the clicking noise dissapeared, but I got an eroor message at startup: "SATA Port1 Device Error" "Press F1 to continue".

I have tried a lot of possible BIOS configurations with no help. Win starts ok from the SSD, and Win 7 installed a device driver (ATA disk), but its not showing any info on the drive.

WD diagnostics tool (win) says cable error, and the dos tool says no drive detected.

I feel I'm so close. Any ideas on what to do?
Please help!!!

Report •

Ask Question