WD external hard disk drive unable to be used

June 9, 2011 at 05:40:20
Specs: Windows Vista
I have a Western Digital external hard disk drive, and I use it on my laptop that runs on Windows Vista. I was playing a game which I installed in my HDD when my laptop suddenly went blank. I managed to restart it, but the HDD that usually appears as 'WD Passport' in My Computer now appears as 'Local Disk (H:)'.Whenever I try to double click on this 'Local Disk (H:)', My Computer stops responding.

Here's a list of things I did in effort to find out what was wrong/ resolve the issue:

1. I used a different HDD on my laptop. It worked perfectly well

2. I used the affected WD HDD on another laptop, and the message 'I/O device error' pops up (this didn't happen in the first laptop, though).

3. Uninstalled the HDD through the Windows Device Manager in hopes that replugging the HDD in will resolve it. This didn't work even after the driver was installed again. (Strangely, the Windows Device Manager still detects it properly)

4. Tried using the safely remove hardware function. This can detect the HDD properly as well, but the problem still persisted when I plugged the HDD back in.

Obviously, none of my attempts worked. It should be noted that throughout the whole time, the blue light on the HDD remains lit, so it's probably still functional.

I don't usually use the 'safely remove hardware' function, and I'll just unplug the HDD when I'm done. I heard this could be the reason for the problem.

I've got quite a number of files that I'd really like to keep, so I'd appreciate it if someone could tell me how to solve this with my data intact. But in the worst case scenario, I don't mind formatting the entire thing as well. I did try formatting it, but I couldn't do so when I couldn't even click on 'Local Disk (H:)' or anything related to the HDD that would let me format it. So if saving my HDD with the data is impossible, it'll be great if someone could tell me how to format it in this situation.

I really hope someone can help!

See More: WD external hard disk drive unable to be used

Report •

June 9, 2011 at 09:04:11
Look for the external in Windows Disk Management. If listed there highlight the drive icon and then post all the information listed for that drive.

Report •

June 9, 2011 at 19:08:24
I opened Windows Device Manager and clicked on it. All it said was that 'this device is working properly'...

Report •

June 9, 2011 at 23:07:11
I said "Windows DISK Management", not Device Manager.

Report •

Related Solutions

June 9, 2011 at 23:54:24
Oh okay, here's the listed information for (H:)

Layout: Simple
Type: Basic
File system: RAW
Status: Healthy (primary partition)

Report •

June 10, 2011 at 00:02:46
OK, you have corrupted the partition. Probably by NOT using the safely remove function.

You may be able to repair the partition by using a utility called testdisk. Get testdisk at the link below. Be sure to read all the tutorials for best results.

You may need to know what file system was in use prior to this problem. Post the full model name and number and I will attempt to find what file system came on the drive from WD. I am retiring now as it is 3 AM.

Report •

Ask Question