Click here for important information about

W7 mass storage controller driver not working

August 9, 2010 at 05:36:31
Specs: Windows 7
I was checking my device manager because my computer kept messing up on loading my SD cards, after a second or two I noticed my AEMIAEFS IDE Controller wasnt working. I cannot update it with the Update Driver option and dare not remove it.

Any idea on how to fix this?

Note: Here's some general info from the device manager about it.

Device Type: Storage Controller
Manufacturer: (Standard mass storage controllers)
Location: on Extended IO Bus

No driver provider/date/version/signer available

Device status: Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

See More: W7 mass storage controller driver not working

August 9, 2010 at 05:45:25
Did you upgrade to Windows 7 from another OS on that computer? It sounds like your motherboard chip set drivers have not been installed and there are none available in Windows 7.

Report •

August 9, 2010 at 07:15:01
I upgraded from Windows Vista to Windows 7 yes, i'm quite sure it worked before though

Report •

August 9, 2010 at 08:28:09
I don't know what an "AEMIAEFS" IDE controller is. I am guessing it may be an add in controller card. If that is the case Windows 7 may not have a driver for it.

Download and use SIW to determine what you have. Get SIW at the link below.

Report •

Related Solutions

August 9, 2010 at 21:27:16
Under what tab would I look? Sorry, its quite early here

Report •

August 9, 2010 at 22:42:10
Do you mean in SIW? Expand Hardware> Devices> IDE ATA ATAPI controllers.

Report •

August 10, 2010 at 05:07:44
I didnt find it under what you listed since apparently that option isnt there but I did find it in Storage Controllers. The details are as following

Device ID ACPI\PNPA000\4&5D18F2DF&0
Status 0x01806400 Has Problem
Problem 0x00000027 (39)
Service azcmjjak
Capabilities 0x000000f4
Config Flags 0x00000000
Class SCSIAdapter
Manufacturer (Standard mass storage controllers)
Hardware IDs ACPI\PNPA000
Class GUID {4D36E97B-E325-11CE-BFC1-08002BE10318}
Bus number 0x00000000
Enumerator name ACPI
Description AEMIAEFS IDE Controller
Physical Object Name \Device\00000054
Bustype GUID {45203337-2041-3033-2031-352036422030}
Legacy bus type 0x00000000
Install State 0x00000000

Report •

August 10, 2010 at 05:20:53
Post the information from SIW under the Hardware> motherboard listing.

Is your computer a custom built or an OEM pre-built unit? If the latter, post the full brand and model, including the series.

I assume everything, including SD cards, worked under Vista?

Report •

August 10, 2010 at 06:00:39
Everything worked fine under Vista, my usb's and SD cards work again now, but now my external has a USB cable picture with a big X through it o_O

This is the info from hardware -> Motherboard


Property Value
Manufacturer Packard Bell
Serial Number U00E090702264

North Bridge NVIDIA nForce 730i Revision B1
South Bridge NVIDIA nForce 730i Revision B1

CPU Pentium(R) Dual-Core CPU E5200 @ 2.50GHz
Cpu Socket Socket 775 LGA

System Slots 4 PCI

Memory Summary
Maximum Capacity 8192 MBytes
Memory Slots 4
Error Correction None

Warning! Accuracy of DMI data cannot be guaranteed

And my computer is a OEM I guess...

Manufacturer Packard Bell
Product Name IMEDIA D7000 NL

Report •

August 10, 2010 at 06:01:11
p.s. Its a 64 bit Windows 7 Professional

Report •

August 10, 2010 at 06:12:48
Your computer is a pre-built OEM model.

For some reason I suspect that Windows 7 is not properly configuring your hardware. You may need to get the correct drivers and apply them to the computer. In order to do that you need to go to the Packard Bell site and either select the correct model or enter the service tag. Then download all the hardware drivers for Windows 7.

If no Windows 7 drivers are available then you will need to download chip set drivers from nvidia. Below is a link to the Packard Bell site.

Report •

August 10, 2010 at 06:20:45
The packardbell site as usual does not list my particular model... Last packard bell i'l ever buy in my entire life... Cant download updates from the site so any other advice?

Report •

August 10, 2010 at 06:31:39
What is your full model number and series?

Report •

August 10, 2010 at 07:31:57
Manufacturer Packard Bell
Product Name IMEDIA D7000 NL
Serial Number PVU120X00190901CE42701

Report •

August 10, 2010 at 09:07:50
It appears that model was made for the Dutch market. The latest version of Windows supported is Vista. That would explain why you are having problems.

The solution may be to get chip set drivers for Windows 7 directly from the chip set manufacturer. Below is a link to the chip set drivers for Windows 7 x 64

Report •

August 18, 2010 at 03:17:42
My internet was down for a few days so I've not seen your reply until now, il try it out and let you know

Report •

August 18, 2010 at 09:17:29
After installing the update you said the controller is still broken, on the brightside though: The network controller update included in the package made my router work better

Is it safe to say i'l never get the controller working again?

Report •

August 18, 2010 at 09:28:57
If the card reader is not working why not remove it from device manager and reboot. Perform that in Safe mode if possible. Below is a packard bell link. Don't know if it is good for 64 bit or not.

Select Desktop> imedia> pt.u12

Report •

Ask Question