Video card No Signal problem. Red LED on sabertooth Z77.

Asus Sabertooth z77 motherboard (intel s...
December 1, 2012 at 13:31:26
Specs: Windows 7, Intel i7 3770k @ 3.5GHz
Please help with video card/system question.

Just bought a new computer.

The specs are:
CAS: Corsair Carbide 300R Mid-Tower Gaming Case w/ front USB 3.0 [+13]
CASUPGRADE: 12in Cold Cathode Neon Light [+10] (Green Color [+0])
CD: 24X Double Layer Dual Format DVD+-R/+-RW + CD-R/RW Drive (BLACK COLOR)
CD2: None
COOLANT: Standard Coolant
CPU: Intel® Core™ i7-3770K 3.50 GHz 8MB Intel Smart Cache LGA1155 (All Venom OC Certified) [+116]
CS_FAN: Maximum 120MM Color Case Cooling Fans for your selected case [+15] (Green Color [+0])
FAN: Thermaltake Water 2.0 Performer Liquid Cooling System 120MM Radiator [+35] (Single Standard 120MM Fan)
HDD: 2TB (2TBx1) SATA-III 6.0Gb/s 64MB Cache 7200RPM HDD [+27] (Single Drive)
HDD2: 64GB SanDisk SATA III 6.0Gb/s SSD - 490 MB/s Read & 240 MB/s Write [+60] (Single Drive)
IUSB: Built-in USB 2.0 Ports
KEYBOARD: AZZA Multimedia USB Gaming Keyboard
MB_SRT: None
MEMORY: 8GB (4GBx2) DDR3/2133MHz Dual Channel Memory [+17] (G.SKILL Ripjaws X [+7])
MONITOR: * 24" Widescreen 1920x1080 ASUS VS247H-P LCD [+157]
MOTHERBOARD: [CrossFireX/SLI] ASUS Sabertooth Z77 Intel Z77 Chipset DDR3 ATX Mainboard w/ Lucid Virtu MVP, TUF Thermal Armor, 7.1 HD Audio, Intel GbLAN, Display Port, 3x PCIe x16 (2 Gen3, 1 Gen2) & 3x PCIe x1 (All Venom OC Certified) [+184]
MOUSE: AZZA Optical 1600dpi Gaming Mouse with Weight Adjustable Cartridge
NETWORK: Onboard Gigabit LAN Network
OS: Microsoft® Windows 7 Home Premium [+104] (64-bit Edition)
OVERCLOCK: No Overclocking
POWERSUPPLY: 1,000 Watts - Cooler Master Silent Pro Gaming 80 Plus Power Supply [+133]
VIDEO: AMD Radeon HD 7970 3GB 16X PCIe 3.0 Video Card [+371] (Major Brand Powered by AMD)

When I got the computer I took it out of the box, took off the case cover and made sure all the connections were secure, after that I tried hooking it up to my monitor and got a "No signal" message on the monitor, but everything else in the computer was running. (No windows was not booting, no the computer did not turn off itself after any amount of time, and yes the video card was connected to the powersupply properly and the video card fan was spinning.) It just sat there with the no signal message on the monitor and the red LED light on the PCI-E slot of the motherboard active so I investigated.

First I called cyberpower tech support and told them what was happening. They had me re-seat the connections, RAM, and video card. That did not solve the problem. They said that they think the video card was DOA because I tested the computer with my old video card (Nvidia 9800 GTX+) and everything worked perfectly.

I researched to find out that there was issues with the ASUS Sabertooth Z77 and some video cards causing the red LED light on the first PCI-E slot to be activated indicating a "VGA error". This was a BIOS bug. So I flashed my BIOS to the latest version (1708) people have said this fixes the red LED no signal issue, but the problem continues for me.

Can anyone help me with this problem?

See More: Video card No Signal problem. Red LED on sabertooth Z77.

December 1, 2012 at 13:40:47
I would say that since the system works properly with another GPU, you have a GPU problem. Try getting a new one. If it's new, I hope you kept the receipt.

Report •

December 1, 2012 at 13:43:49
After u flashed the BIOS did u clear the CMOS?
Test HD 7970 with 1000W PSU in another working system to see if it is real dead.

You know the real meaning of peace only if you have been through the war.

Report •

December 1, 2012 at 13:59:49
I connected it to my old PC, and it had no signal. Post boot beep followed by 2 more short beeps indicating a VGA error probably. I guess the video card was just DOA. When I called them i forgot to say, if a part arrives DOA you just have to RMA it. In this case, they said the video card is bad, so they're sending me a new 7970 and I have to send the old one back in the same box once I get the new one.

Another interesting fact is that my ethernet port was not working even though the device was connected to the computer indicating it was not a bad onboard part. I i looked at the pins and 2 of them were smashed in so I spent like an hour pulling them out with tweezers while everything on the pc was unplugged lol. Looks like someone (maybe UPS) just threw it around too much and the video card broke.

Report •

Related Solutions

December 1, 2012 at 14:01:29
But no I did not try to reset the CMOS after I flashed. I will probibly try that later on tonight.

Thanks for the quick reply.

Report •

December 1, 2012 at 15:16:54
So, does the system work using the on board graphics?

Report •

December 1, 2012 at 20:48:39
I will check now, thanks for the suggestion.

Report •

December 1, 2012 at 21:40:53
Ok, onboard graphics works. Took a while to figure out why it was not working at first.

Report •

December 3, 2012 at 12:31:19
Any more suggestions?

Report •

Ask Question