Video card causes memory errors

Asrock / N-68s
April 10, 2010 at 07:53:21
Specs: Windows 7
Worked fine for 2 months. Was getting random lockups (within 15 mins of turning on). Took the computer apart and tested each one at a time. If I put my 9500gt in the pci-e slot and run memtest, I get errors. If I take it out and use the onboard....everythings fine. tried all kinds of bios settings with no help.

amd x2 6000+ 4 gig ram asrock n68s

tested memory for hours without it in there with no problems. HELP.... :)

See More: Video card causes memory errors

Report •

April 10, 2010 at 10:14:08
"Product: Asrock / N-68s"

The Asrock web site does not list N68-S

The closest is N68-S3

Find your actual model name.
Model name finding

My guess is you need to change the ram timing numbers in the bios Setup so they're a bit slower (higher numbers). You probably won't be able to perceive the difference the slower timings make, otherwise.

Sharing the ram with the onboard video drastically reduces the ram's bandwidth (max data transfer rate) - it as much as halves it (you can use a program such as one in Sysoft Sandra suite to confirm that).

When you install a video card in a PCI-E X 16 or a AGP slot, in almost all cases, doing so disables the onboard video, and if so, the onboard video port produces no video when there is a card in the dedicated video slot, the ram is no longer shared with the onboard video and the bios settings regarding that are ignored by the bios, and the ram is able to perform at it's full bandwidth.

I think it's quite possible that what is happening is the ram is producing ram errors when the ram is able to use it's full bandwidth.

Assuming all the ram you have installed in the ram slots is 100% compatible with using it in your mboard model (it might not be) , then the most likely things are

- the default ram timings in the bios are not correct for your particular mboard model, and/or your mix of ram modules has more than one voltage specified for it.

Some ram manufacturer's modules do not strictly adhere to the JEDEC standards that most mboards bioses use to determine ram settings.
In that case, the ram settings in the bios Setup that the bios has automatically chosen may not be correct.
Check the ram settings in your bios - the ram voltage, and the ram timing numbers - those should be the same as for the specs for the modules themselves. Often the ram voltage and timing numbers are printed on the label on the modules.

If the voltage setting or timings settings in the bios are different from the specs for the ram, change them in the bios. The timing numbers must be as close as you can get to the same, or slower timings (higher numbers = slower) - you won't notice the difference the slower settings make.

If you have a mix of different modules
- don't mix ram that different voltages arespecified for - the bios will force the ram to use the lowest voltage, if "by spd" or similar is used (default settings) - ram that a higher voltage is specified for is more likely to not work properly in that situation.
- the bios settings must be those for the slowest timing settings of all the modules, or slower (higher numbers = slower).

- OR - at least one of the ram modules was made by an "also ran" ram manufacturer. According to info the Mushkin web site, some "also ran" ram manufacturers rate the ram timings of their modules when only one module is installed in a mboard, such that the ram timing are a bit faster (lower numbers). When more than one ram module is installed in a mboard, those modules may produce ram errors. If you change the ram timing numbers in the bios so they are a bit slower (higher numbers), the ram works fine.

e.g. we've heard of people having to do this several times for G.Skil ram .

Report •

April 10, 2010 at 10:56:43
Thanks, I tried another pcie card and it also caused the errors, then took it out and all is good. I will start changing the timings........the only problem is the ram is generic and has no name on them at all. This might be trial and error the rest of the day. Thanks for your input, I wanted to lean toward that being the problem....just wasnt sure.
Before I was using the asrock oc tuner and recently got rid of is very possible the voltages were correctly being controlled through it. Will follow up later THANKS!!

Report •

April 10, 2010 at 11:23:39
You can use a program such as CPU-Z to find the SPD info for the ram modules. The SPD info is on a tiny chip on one end of each module and has had read-only data entered into it by the ram manufacturer - the timing numbers at specific mhz, the ram voltage, etc. However, sometimes generic module manufacturers don't fill everything in.

If the bios is set to detect the ram "by SPD" or similar, it reads the SPD info on all the modules and uses the least of the settings (the slowest settings) of those for all the modules if any are different.

Report •

Related Solutions

April 10, 2010 at 15:30:33
Thanks.....but yes, these chips are generic and none of the programs give me the correct timings, but I assure you I tried every combination over the last 3 days.

I installed the asrock oc tuner again and turned the pcie bus down to 92mhz and its stable again.

SO, this means the memory isnt completely compatible with the board?? The bios only lets me set the pcie bus at 100 mhz and thats why I couldnt fix it any other way.

If I do a memtest, the tuner doesnt work though and it gets one or two errors every pass, random addresses.

Whats the disadvantages of running the pcie bus low?


Report •

April 10, 2010 at 15:58:35
One or two errors every pass of the long set of tests - you are using that aren't you? - could easily be caused by a poor connection of the ram in the slots.
See response 2 in this - try cleaning the contacts on the ram modules, and making sure the modules are properly seated:

"I installed the asrock oc tuner again and turned the pcie bus down to 92mhz and its stable again.
Whats the disadvantages of running the pcie bus low?"

At most, an 8% performance decrease, but that may affect only the video performance, which you may not notice at all.

As I said above, you can use ram that you can't find listed as compatible with your model, as long as it passes the long set of ram diagnostics tests.

You could try setting the bios to defaults, finding the ram timing numbers the bios is using - x-x-x-x , then custom setting those numbers to higher - slower - values , with the PCI-E bus at 100mhz.

Report •

April 10, 2010 at 16:53:41
okay, everest report:

CAS latency 6T
RAS To CAS delay 4T
RAS Precharge 4T
RAS Active Time 11T
Command Rate 2T
RAS To RAS delay 2T
Write Recovery time 4T
write to read delay 3T
read to precharge delay 4T
four activate window delay 10T
refresh period 7.9us
dram drive strength 1.0x
dram data drive strength 1.0x
clock drive strength 1.0x
cke drive strength 1.0x
max async latency 6ns
idle cycle limit 16
dynamic idle cycle counter enabled
read/write queue bypass 8

error correction
ecc supported, disabled
chipkill ecc supported, disabled
raid not supported
dram scrub rate disabled
l1 data cache scrub rate disabled
l2 cache scrub rate disabled

Report •

April 10, 2010 at 21:09:35
5 hours of web/some heavy gaming and no lockups, eased the pcie bus back to 99.8, but any higher and it freezes. Thanks guys....guess I will leave it as is for now . Thanks for the help. Next time I will buy BRAND name memory.

Report •

April 10, 2010 at 21:15:46
"okay, everest report:

CAS latency 6T
RAS To CAS delay 4T
RAS Precharge 4T
RAS Active Time 11T "

Memory timings (or RAM timings) refer collectively to a set of four numerical parameters called CL, tRCD, tRP, and tRAS,.....

You may be able to custom set any of those so they're higher numbers (slower timings) in the bios.

Report •

April 11, 2010 at 09:33:38
yeah, tried.....but the seller of the memory wrote me back finally and said they are the wrong density and some other technical terms. For 32 more dollars he will exchange them for the asrock certified ram. So I guess this is case closed for now until I can afford some more ram.....Ive got 5 kids to take care of. I will just have to be happy with what Ive got now, thanks for all the help guys!!!!!!!!!!!!!!!!!!!! Great forum A+

Report •

April 11, 2010 at 11:23:01
OK. We're glad we were of some help.

There are several things that have to be right for the ram to be 100% compatible - the density of the ram organization is only one of them, and I doubt that applies in this case because if the ram density were too dense the ram would either not be recognized at all, or only part of it's size would be recognized - e.g. half of it.

It doesn't have to be Asrock certified as long as it's listed as compatible for the mboard model when you use the model to search with on a ram manufacturer's or ram distributor's web site - they know more about which ram will work than the mboard manufacturer's do, the mboard model's info sometimes originally has incorrect info about the ram, and the mboard manufacturers test only a relatively small number of modules.
Brand name ram is frequently on sale these days, or has a mail in rebate available for a limited time, so brand name ram need not be expensive.

Report •

April 18, 2010 at 18:33:43
........verdict is in
asrock mb dont support 8600's

asrock and the card manu said to buy something newer....just bought both of them though, will never buy asrock again

Report •

April 19, 2010 at 07:29:22
8600 what ?
A Geforce 8600 PCI-E video card ?

You haven't mentioned 8600 anything previously.

Do you mean 9500GT ?

Report •

Ask Question