USB2.1 requires Pentium but have AMD K6

Belkin Hi-speed usb 2.0 5-port pci card
September 22, 2009 at 05:19:13
Specs: Windows ME, 300Mhz/128Mb
Picked up an old Computer running AMD K6 300Mhz with 128Mb RAM running on WinME that has no NIC nor USB.
Want to use it for my daughter to do her homework using MS Office 2K that was installed already.
It does have a floppy drive that can be used to transfer data to the other PC that has the printer but would like to add USB PCI card so she can use a flash/thumb drive to transfer data and or connect an available USB NIC.

I purchased the Belkin 5 port PCI card and have an available slot but the package states the system requirement to be a Pentium processor with OS which includes WinME

Do I meet the requirements? Is a AMD K6 a Pentium class processor in this context?


See More: USB2.1 requires Pentium but have AMD K6

Report •

September 22, 2009 at 07:09:07
Oh man you're taking me back to happier times.

The k6 was a Pentium 1 equivalent.

Report •

September 22, 2009 at 08:56:02
Should work fine Bryan. As a side note, the machine would appreciate another 128Mb stick of memory.


Report •

September 22, 2009 at 10:10:31
You both have confirmed my understanding.

The Mobo uses EDO or SDRAM and came with 2x32EDO.
I replaced it with 2x64Mb SDRAM that I had lying around.

It also has a 3Gb hard drive.

It is good for doing homework.

I picked it up from the trash in front of a house that had a for sale sign on it. I thought, maybe it was a good PC.
Got it home to find It is good but vintage early 1998.

Thansk again,

Report •

Related Solutions

September 22, 2009 at 10:32:12
Mboards of that vintage usually had no physical USB ports built in, but some made after about 1994? DO support USB 1.0, or later ones, USB 1.1, and have a USB header you could connect a wiring adapter to that installs at the end of a spare card slot space - a plate with one or two USB ports in it.
If it has that, there's a USB controller in the bios Setup you can enable/disable.

If you see that, you need to / we could determine which pins on the USB header connect to what.
Which pins are for what on a USB header was never standardized, and there were all sorts of ways the pins were wired up on the mboard in those days.

We may be able to find you a manual in any case.
State the make and model of your brand name system, or if it is a generic system, the make and model of the desktop mboard.
The specific brand name system model is usually on a label on the outside of the case somewhere, or it can be determined by going to the brand name's web site. The model of the mboard in a generic system is usually printed in obvious larger characters on the surface of the mboard, often between the card slots.

If you see nothing like that, or an alternative is, if the motherboard is in a working system...

Go here, download BIOS AGENT.
Run BIOS AGENT to find your bios string.
- here's the link that downloads Bios Agent

The current Bios Agent calls the bios string the Bios ID.
Tell us the Bios ID it finds, or everything Bios Agent finds, and include any dashes, etc.

Your mboard MIGHT be an early Super Socket 7 and supports K6-2 cpus, and in that case you could run a K6-2+ 550 cpu at up to 600 mhz.

Report •

September 22, 2009 at 13:01:46
The Motherboard BIOS has to have USB Support and an AMD K6 should, the motherboard will likely have a 10 pin USB Header, if not you are out-of-luck.

Best thing is to install a Network Card and create a network with existing PC/Laptops

Report •

September 22, 2009 at 13:14:05
I'd like to know the motherboard manufacturer and model too Bryan.

BTW, the 300Mhz came in K6 and K6-2 flavors. K6 @ 66Mhz fsb and K6-2 usually @ 100Mhz fsb.


Report •

September 22, 2009 at 14:15:45
I'm guessing it's one of those super socket 7 AT boards from Asus or PCchips? For those you could get the ATX Form Card:

Of course that's only USB 1.1. As I recall, if you used an add-on 2.0 card you still needed to enable the on-board USB support even if you didn't have a form card connected.

Report •

September 23, 2009 at 05:10:07
I am presently at work but do believe the Mobo was EP-MVP3C2 (pretty close to positive).

On another IE tab I am trying to get the manual at but it is failing to produce anything. I expect the website to timeout before it produces anything.
They also have a link for USB 2 support.
I'll try these from home tonight.

Thanks for the input,

Report •

September 23, 2009 at 08:44:39
Update - mboard model names corrected in this.

I am typing this on a system with an EP-MVP3G5, the last and best one in Epox's series of MVP3 mboards. I have a K6-III 450 on it. I bought it new in Dec. 1999 and have been using it ever since. A have a system with a faster mboard and cpu I use for XP, but I use this system with this mboard the most. It's a full size ATX mboard, has two built in USB 1.1 ports. It has the last and best revision of the MVP3 chipset - it supports ATA/UDMA 66.
My Dad is using an EP-58MVP3C-M (AT mboard) upstairs connected via a wired connection to my router downstairs.

Epox has had serious financial difficulties in the last few years and I don't think they're making any new mboards anymore.

The site has always been slow loading for me, and sometimes in the last year or so it won't load for me at all.

If you actually do have EP-MVP3C2,
get mvp3c.pdf here:

That's definately a Super Socket 7 mboard, and it's manual is dated 1999, so it probably first came out in early 1999, not 1998.

You would probably have no problem running a K6-2 550 on it, since the EP-58MVP3C-M upstairs is running fine with that, and you MAY be able to run a K6-2+ 550 (they were made for laptops, use a lower core voltage) at 600mhz - all K6-2, K6-2+, and K6-III cpus interpret the X2 multiplier on the cpu itself as X6 - since I can do that on the EP-MVP3G5.

If you have the EP-58MVP3C-M, PM me and I can send the manual to you.

The ram info in the manual is incorrect. Each ram slot can use up to 256mb modules, but they MUST have 16 chips, not 8. You can find the correct 256mb modules by searching for ram for mboards that have the MVP4 chipset.

The only reliable working Epox site left is the Epox Store in California.
They're attempting to sell off the remaining Epox mboards, and other Epox parts, but most of the listed mboards are sold out.
A bonus is you can order a new bios chip for any of their models that had a bios chip in a socket, with is most of if not all of them, flashed with the last available bios version, for only $10 plus shipping. To see the list of mboards the bios chips are available for, you have to go through the motions of placing an order - if your model is not listed, email them - they can probably supply it.
They ship to Canada as well as the US, but when I ordered a mboard from them (I'm in Canada), I was charged extra by UPS, GST and a handing charge were added on, and the shipment sat in a warehouse for several extra days, once the shipment crossed the border. (That's typical for when someone in Canada orders from a US web site, except for from, which uses a special UPS shipping method to ship to Canada.)

According to my experiences with the EP-MVP3G5 and EP-58MVP3C-M.....

- the Award bios version MAY have a bug or bugs that prevents Standby from working correctly. You'll know whether it does have the bug or bugs the first time it goes into Standby mode - it won't come out if it.
In that case you can make do by disabling Standby. In ME and previous, run msconfig - look at the program listed under Startup - disable both "load power profile" lines from loading.
In 2000 and XP, go to Control Panel - Power Options and set System Standby to Never if it isn't already set to that. Similar applies to Vista and Windows 7.
You can still set the Power Options to turn off the monitor and hard drives in xx minutes - that will work fine - merely moving your mouse switches it or them on again.

- the Award bios version may have a bug or bugs in it that prevents hard drives larger than 32gb, or 64gb, from being recognized as their full size, or that freezes the intial boot at the point when the bios is detecting a drive larger than that.

There is a later bios version, which I have, for the EP-MVP3G5 that fixes that, and there is a bios version for the EP-58MVP3C-M, which I have, that was patched by a third party to get rid of that problem. If your mboard actually is EP-MVP3C2 there MAY be a patched bios version for that that I could dig up on the web.

In any case, the Award bios version and the MVP3 (and MVP4) chipsets cannot recognize the full size of any hard drive larger than 128gb in Windows and the bios / = 137gb manufacturer's size - they see it as 128gb. If you need to support a hard drive larger than that, get an inexpensive PCI IDE (a.k.a. EIDE, PATA) drive controller card and connect the drive to that (or a PCI SATA drive controller card if you like) , but if you want to be able to support connecting CD or DVD drivesto it, the description must say the card's chipset supports ATAPI, and/or ir supports connecting CD or DVD drives to it.

- the amount of ram that is cached by the L2 cache chips built into the mboard is directly dependant on their size.
E.g. My EP-MVP3G5 L2 cache chip is 2mb - it cachesup to 512mb of ram. Older models have a smaller L2 cache chip.
If you install more ram than the L2 cache capacity can cache, NONE of the ram is cached, and you take about a 40% performance "hit" regarding the performance of the ram.

- the K6-III and K6-2+ (and K6-III+ but I've never come across one) cpus have an L2 cache built into the cpu. If the bios version supports recognizing the cpu type that has that L2 cache in the cpu, the L2 cache built into the mboard is used as an L3 cache, and the cpu gets a performance boost that is equivalent to you having a faster cpu. If the mboard manual mentions K6-III cpus, even the original bios version probably supports recognizing them properly. K6-2+ and K6-III+ cpus, which were made for laptops and use a lower core voltage, came along later, and some desktop mboard bios versions don't natively recognize they have a L2 cache - in some cases there are bios versions available that have been patched by athirdparty to support the version recognizing K6-2+ or K6-III+ cpus.

E.g. On the EP-MVP3G5, with the last available bios version, Sisoft Sandra rates the
- K6-III 450 with the multipier set to X4.5 at 100mhz (450 mhz) as equivalent to a cpu running at 541mhz.
- K6-2+ 550 with the multiplier set to X2 (= X6 on the cpu) at 100mhz (600 mhz) as equivalent to a cpu running at 721 mhz
(so the last bios version does recognize K6-2+ cpus properly).

Report •

September 23, 2009 at 12:23:13
That's not one of the motherboards that uses the ATX form card. The board probably has the 9 or 10-pin USB header to accomodate one of these:

but you've already got the 2.0 card and it should work fine. Just enable the on-board USB support even if you're not using it.

Report •

September 23, 2009 at 13:23:39
Update - mboard model names corrected in this.

The EP-MVP3C2 is an AT mboard but it definately has a USB header.
USB Connector shown page 14 of the pdf manual on mboard diagram near bios chip socket.
However, how to hook it up was omitted from the manual .


- for EP-58MVP3-M versions (AT)
- wiring / pinout info for the USB header is in the manual

Bios Setup
PNP/PCI Configuration
- Assign IRQ for USB - Enabled (default) / Disabled
Integrated Peripherals
- Onchip USB - Disabled (default) / Enabled
- No USB Keyboard setting in bios settings in manual

- for EP-MVP3C and EP-MVP3C2 versions (AT)
- NO wiring / pinout info for the USB header - it's same as for the EP-58MVP3-M versions

Bios Setup
PNP/PCI Configuration
- Assign IRQ for USB - Enabled (default) / Disabled
Integrated Peripherals
- Onchip USB - Enabled (default) / Disabled
- USB Keyboard support - Disabled (default) / Enabled

- for all Epox MVP3 ATX or mATX mboards

- 2 built in USB ports, no USB header.
Bios Setup
PNP/PCI Configuration
- Assign IRQ for USB - Enabled (default) / Disabled
Integrated Peripherals
- Onchip USB - Enabled (default) / Disabled
- USB Keyboard - Disabled (default) / Enabled

One piece connectors like the following WILL NOT work with the USB header on any of the Epox MVP3 AT mboards.

You can email the Epox Store - they will respond within a day or so, or, at least, they did when I ordered a mboard from them about a year ago (AD580-XR) . (They respond Monday to Friday, reg office hours, Pacific time).

If you get a generic wiring adapter, common ones that have a pair of 4 in a row female connectors will work if they're wired right. Clues are - the wire for +5v is usually red, the wire for ground is usually black, the other two wires for data are another color and have to be between the wire for +5v and the ground wire for this header.

Report •

September 24, 2009 at 04:41:57
Tubesandwires, Sorry to have made you type all of that when I was mistaken.

The correct Mobo is EP-58MVP3C and Epox has a dead link to it's manual and cannot find a copy anywhere so far.

I'll keep looking.

I will be opening it's box again this coming weekend and will look for the USB header.

Otherwise, I suspect the PCI card will work fine and I will enable USB in the BIOS too.

Thank you all,

Report •

September 24, 2009 at 07:12:38
I found a copy of the manual mvp3c-m.pdf from

I'll have a look at it over this coming weekend.

Thanks again,
P.S. DAVEINCAPS - Your items may come in handy later Thanks.

Report •

September 24, 2009 at 09:33:00
"The correct Mobo is EP-58MVP3C "

When you quote something, make sure what you quote is correct!

I have found zero evidence that model exists, but EP-58MVP3C-M does.

EP-58MVP3C-M - No date - (manual version) V021

EP-58MVP3C-M - No date - (manual version) V120

EP-58MVP3C-M - No date - (manual version) V121

16 pin header - CN1 - beside end of third PCI slot from middle of mboard

side with 1 - only side used - 1 to 8 on that side

USB port 0 - 1 to 4
USB port 1 - 5 to 8

1 VCC (+5v)
2 Data 0 -
3 Data 0 +
4 Ground
5 VCC (+5v)
6 Data 1 -
7 Data 1 +
8 Ground

Many generic USB port wiring adapters / case ports with 2 - 4 in a row female connectors, or individual connectors for each wire, would work fine with that.
Obviously a one piece 8 or 9 wire female connector would not work with that header.

The bios version probably must support USB in order for you to be able to use the USB 2.0 card, which obviously it should since the mboard supports USB, but I don't know if both of these must be enabled even if you don't use the onboard USB :
Bios Setup
PNP/PCI Configuration - Assign IRQ for USB
Integrated Peripherals - Onchip USB - Disabled (default) / Enabled

My Dad's computer's mboard - I was mistaken, it is a EP-58MVP3C-M - has that USB header but I haven't tried using it - I have no suitable adapter; his case has no USB ports - or installing a USB 2.0 card on it, although I could try the latter, since I have two of those available.

The stuff I mentioned in response 9 probably applies to your mboard too.

If you want to flash the bios with the patched bios version that supports recognizing hard drives up to and inc. 128gb in the bios and Windows = 137gb manufacturer's size, PM me.
That worked fine with my Dad's EP-58MVP3C-M. The original owner wanted it to support recognizing an 80gb drive properly and it didn't originally.However, the patched bios update does not come with the Award flash utility needed for it. I have saved all the files necessary for a flash floppy, including an Award flash utility that works fine with the patched bios update - you just copy them to a bootable floppy.
However, NEVER flash your bios unless the present version doesn't support recognizing the full size of a drive you're using, AND thingscan go wring while flashing - it's far safer to get yourself a inexpensive PCI hard drive controller card which will recognize any size of hard drive, no problem.

Report •

September 25, 2009 at 06:04:50

Thank you for the info...
"wanted it to support recognizing an 80gb drive properly..."

The PC currently has a 3Gb HDD and the manual shows a max of 8.4Gb.

I do not suspect I will change the HDD but would like to reserve the option to take you up on your offer for the BIOS update at a later time.

Again, sorry about the Mobo model number.
I am adding the USB for the above noted reason in addition too adding a USB flexible keybaord for my daughter's birthday cooming up in the begining of October so do not want to reopen the case until then.

Once I do I will add the USB PCI card without enabling the onboard USB and update the results on this post in case anyone is interested

Thanks to all,

Report •

September 25, 2009 at 11:14:40
".... the manual shows a max of 8.4Gb...."

The info in the manual is rather vague. My manual for the
Manual Revision 10.0 - July 14 1999 shows the same thing, but according to feedback I've gotten, and info on the internet, it's original Award bios version was probably new enough - dated Aug xx 1999, that the bios version was able to recognize at least up to and inc. 32gb hard drives properly because the bug / bugs regarding not being able to recognize hard drives larger than 8.4 gb had been discovered and had been corrected in new bios versions and in bios updates in mid 1999. I had a 13.66gb drive on the system with the EP-MVP3G5 mboard until recently (I bought at the same time I bought the mboard, Dec. 1999; it still works, it's a Maxtor, but I thought nearly ten years use was long enough and I shouldn't risk using it any longer) and the original bios version recognized that properly.
I flashed the EP-MVP3G5 bios version to the last available version because I read somewhere that doing that cured the not coming out of Standby problem I mentioned in Response 9 with other Epox mboards made about the same time - it appears it did do that, and I now have an 80gb drive on the system and the updated bios version recognizes that fine.
If the bios version doesn't have the > 64gb recognition bug / bugs then it will recognize any drive up to and inc.128gb in the bios and Windows = 137gb manufacturer's size.

"Once I do I will add the USB PCI card without enabling the onboard USB and update the results on this post in case anyone is interested"

I predict the USB 2.0 card willl work regarless of whether those two settings are turned on in the bios, although you may not be able to enter the bios Setup with a USB keyboard connected to the card if they're disabled - you may not be able to do that in any case when the keyboard is connected to the card.
As I have just recalled, I believe only Win 95 versions OS2 or later (OS2 being the minimum version required to support USB controllers) require that the mboard's bios supports USB. I recall I installed a PCI USB 1.x controller card on a old Pentium computer that had a mboard bios with no USB support, and that card worked fine in Win 98 and above.

In all the versions of the EP-58MVP3C-M manuals

"- No USB Keyboard setting in bios settings in manual"

I don't know whether you can get into the bios with a USB keyboard in that case, unless Epox has just omitted there being a setting in the bios similar to this you must enable:
"Integrated Peripherals
- USB Keyboard - Disabled (default) / Enabled"
in the manuals.

Report •

October 19, 2009 at 09:41:37
If anyone is still following this thread....

I put the USB PCI card into the PC and it worked but it moved the PCI graphics card causing it to need to be reinstalled and it no longer likes it's driver so I abandoned the whole thing and grabbed another available PC running Win 98 1st edition (P11 300Mhz with 128Mb RAM) that already had 2 usb Slots that the USB keyboard worked on but showed a keyboard error during startup so hooked up the USB keyboard to the PS2 connector using the adapter that came with the keyboard and all is working fine as such.

I may, at a later time, use the USB PCI card in the later PC.

Thanks and regards,

Report •

October 19, 2009 at 11:15:25
I know with 98 and maybe ME, moving a PCI card to another slot causes the OS to 'lose' the drivers. Even if changing the slot causes an address and IRQ change it doesn't seem like it should lose the drivers. Doesn't seem to be a problem with XP though.

Report •

Ask Question