USB ports not working properly

August 6, 2012 at 09:54:24
Specs: Windows 7 Service Pack 1
Hello. I have three USB ports on my Windows 7 computer. All three have recently started playing up. They can recognise a device but if I physically move the device (ie. mouse) the computer loses the connection then finds it again. It is constantly making that 'beeping' sound it makes when you plug/unplug a USB device even though the USB connection is in securely. Does this sound like a physical issue with the laptop or something I can fix? I have tried updating drivers but they are up to date. I have also tried removing USB devices from device manager but it didn't fix the issue.

See More: USB ports not working properly

Report •

August 6, 2012 at 10:03:04
Is the mouse the only device which acts like that? If so, it might be the mouse is not functioning properly. Try it on a different PC to verify.

Google is your friend


Have a GREAT day!

Report •

August 6, 2012 at 10:11:26
Thanks for your response. It is happening with every device. Various mice, phone USB connections, kindle connection, etc.

Report •

August 6, 2012 at 12:25:34
Boot into safe mode. Still have the same problem? Run a full scan for viruses & malware.

Report •

Related Solutions

August 6, 2012 at 12:39:36
Might be a current draw issue. One or more devices could be taking too much power. See MS pages on how to show current in usb from hardware in control panel.

Might try a restore point to a time when it worked.

Guess some malware could cause it.

See event logs for more clues.

Google is evil

Report •

August 8, 2012 at 01:58:54
Thank you, I will try those now. I have just tried an externally powered USB device (an external hard drive) and that seems to have no problems. So it sounds like a power issue. Just not sure if this is a physical issue or something I can fix myself.

It's strange. A usb device (ie. mouse) will work fine when I plug it in, but if I move the usb connection the slightest bit it stops working then will work again. Every time the connection is moved it plays up. I would think it was a loose connection but it is happening with all three usb ports and they all started playing up at the same time. They are all in properly. It also happens when only one device is connected so it can't be using too much power for the laptop surely. It is a relatively new laptop too.

Anyway, I will try your advice. Thank you!

Report •

Ask Question