USB port not working on Dell inspiron laptop N5110

August 4, 2012 at 02:37:55
Specs: Windows 7, 4 gb , core i5
my operating system is windows 7-64 bit , dell inspiron n5110 core i5 , usb port of right and rear side is not working i reinstall the driver renesas but still not working , i tried winterson driver but that driver doesn't work , pls help me urgent , pls pls.

See More: USB port not working on Dell inspiron laptop N5110

Report •

August 4, 2012 at 02:55:19
Have those ports ever worked before?
Is your machine still under warrenty?

When you plug a device into the usb ports do you hear and sounds? Or do you recieve any error messages?

Report •

August 4, 2012 at 05:40:48
Actually ports was working well , but somedays before these ports stopped working ,secondly in icons on taskbar windows shows usb not recognized , and another thing when i click on "USB 3.0 Host controller utility " it give me a warning controller not found

Report •

August 4, 2012 at 07:37:45
Try reinstalling the chipset driver, then the USB driver.

Report •

Related Solutions

August 4, 2012 at 09:55:31
can you pls tell me what is this warning controller not found

Report •

August 4, 2012 at 10:34:36
Did you accidentally disable the USB controller in the BIOS? Or could it be that you don't actually have the NEC USB controller on your motherboard? Did you install the chipset driver like I suggested?

Report •

August 5, 2012 at 02:45:28
i installed it but still nothing happens , just wriiten "Windows exploler USB device not recognized
" .............. and how to check if i had disabled usb controller in bios ????????????????

Report •

August 31, 2012 at 06:43:39

To ensure the card on which you have the USB ports hasn’t gone bad, Please check if the Ethernet port on the rear side of the computer and Headphones jack on the right side of the system are working or not?

I would also suggest you to run the Online USB Diagnostics by clicking on the URL mentioned below:

If Ethernet port and Headphones jack test fail or even the online USB diagnostics fail, then it’s an issue with the Daughter Board card. I would suggest you to send me a Private message with the details of computer like: Service Tag & contact number. Kindly don’t share your Service tag in the open forum.

If both tests pass, I would suggest you to download the Wistron-Driver again and reinstall it from the URL mentioned:

You can also try removing the USB root hubs. In device manager, under USB controller, you will find many USB root hubs, right click on each one of them and click on uninstall, and remove all of them, and restart your computer. Windows will see the "New" device and then try to install the drivers.

If that doesn't fix the issue, then you need to update Chipset Driver. Download and install the chipset driver from the URL mentioned below and restart your computer:

Kindly get back if there are any further queries.

Thanks & Regards
Debbie B

Report •

Ask Question