USB Mouse keeps disconnecting itself

Gateway Nv5389u notebook
September 27, 2011 at 18:13:22
Specs: WINXP, AMD 3200+
I need to know if my mouse is broken or if my usb drivers/ports are compromised.

My mouse is a mx510 (from logitech) and recently for no reason it keeps shutting off while connected via usb port. Sometimes it comes back up and sometimes i need to plug it in again for it to continue to work.

When it shuts off there is a 'USB has failed to recognize whatever is plugged in' error that pops up.

I have scanned with an anti-virus which came back negative. Spybot/ad-aware tool and so forth and these come up negative.

A curious thing is when i plug my usb mouse into the ps/2 addon (its from logitech) and plug that in the ps/2 port, it works completely fine and doesn't shut off at all. So could the usb part of the mouse be fried.. but the ps/2 part be ok? This makes no sense since the usb part plugs into the ps/2 addon and works through it and is ok.

I have tried multiple USB ports and they all connect/disconnect with the mouse. I have set it so the computer will not turn off mouse if losing power and have installed a new powersupply unit just in case (it was screwing up with old powersupply too)

What kind of drivers do I need to reinstall for my usb? (nothing else that is plugged into the usb malfunctions, except the mouse)

Can i get some ideas guys? :\

See More: USB Mouse keeps disconnecting itself

Report •

September 28, 2011 at 06:20:29
USB mouse drivers are built in to Windows so there are no drivers that need installing for that.

However, you might want to try uninstalling all your built-in usb controllers, then restart Windows and it will re-install the built-in drivers for those same controllers.

Open Device Manager, expand the Universal Serial Bus controllers, right-click each controller in turn and choose Uninstall.

When all are uninstalled, restart Windows.

Before doing any of that however, surely you are capable of borrowing or buying a new USB mouse to see if your existing mouse is faulty? A basic USB mouse for testing purposes does not cost much. I'm surprised you haven't done that already.

Report •

September 28, 2011 at 07:24:49
I'm lazy and poor. So i don't want to do that. I have tried uninstalling the usb in device manager and then reinstalling them, same problem. Also disconnected the computer from the power source for 30 min and then put it back and had same problem. Did system restore, 2 months rollback, same problem. Uninstalled all weird programs and stuff I don't remember installing, same problem..

I tried sfc /scannow but that didn't do anything. Any other ideas?

Report •
Related Solutions

Ask Question