USB Microphone Mixer

Syx / Snc302eeh
May 6, 2009 at 21:29:39
Specs: Microsoft Windows XP Professional, 2.299 GHz / 1918 MB
I bought an Acesonic KM-111 microphone mixer to use during stints on an internet radio station. It came with very little documentation, but I'm a guy, who reads the instructions anyways. Plugged it in, XP recognized it as a USB Audio Device. Went into control panel, to test it. Selected the USB Multimedia Device as my input choice. Microphone will not register and sound. Unistalled and tried again, volume meter was pegged. Ok, unistalled again in device manager and put in the cd-rom that came with it. Installer starts up and says to please plug in the "USB Multi-Channel Audio Device" and install driver again. I plug it in, XP recognizes it and tells me my hardware is properly installed. The installer software won't recognize that this happened. After many hours of research I have deleted the upper and lower filters in the bios, and uninstalled anything that had to do with Logitech webcams per other people suggestions to no avail. Any further ideas would be greatly appreciated, as I am at a loss. I found the installer software online and tried a different version of it, same issue. There are a few sites that say maybe it has to do with being a Dual Core CPU. Anyways, hopefully there is someone out there smarter than I am. Thanks for any help.

See More: USB Microphone Mixer

Report •

Report •

May 7, 2009 at 12:22:29
Yeah, tried that yesterday. 3 emails with no response and about an hour being on hold leaves their technical support line pretty much useless.

Report •

Related Solutions

Ask Question