USB flash drive won't format

March 8, 2013 at 21:41:46
Specs: Windows 7
I have a 4GB ''genx'' USB flash drive.The first time i tried to format it,I couldn't complete the process due to a power failure.

Then I tried to format it again but it won't format at all.
Earlier the format window appeared and once I start the format it gave an error message and won't complete the process.

I tried several times but no good.Now even the FORMAT WINDOW won't APPEAR.

I even tried a software called "HP USB disk format tool" it gives an error message as "THERE IS NO MEDIA IN THE SPECIFIED DEVICE".

Then RIGHT Clicked and opened the properties window.It says the free space as well as the used space is 0 bytes.
I opened tool tab and tried error checking but a message appears saying "THE DISK CHECK COULD NOT BE PERFORMED BECAUSE WINDOWS CAN'T ACCESS THE DISK"

Some one PLEASE help...

See More: USB flash drive wont format

Report •

March 8, 2013 at 22:43:16
Sounds like a defective usb drive. Inside your drive there is a controller and flash memory. If the controller is good but the flash memory is bad the device will report 0 bytes. Unless this is a U3 / virutual drive and the memory is blocked because of firmware corruption on the drive. In that case you could try to find a U3 removal tool from genx for your drive that may fix it. You may also try to use the clean function of diskpart.

Report •

March 8, 2013 at 23:17:48
I tried diskpart but once i gave the clean command it says "the system cannot find the file specified"

Report •

March 8, 2013 at 23:59:44
Looks like you USB drive is gone if you tried all the things I listed.

Report •

Related Solutions

March 9, 2013 at 01:06:51
Yup :( me too.
Thanks for your help!

Report •

Ask Question